
Scalix Migration Guide

Version 11
Revision 3
1



Scalix Migration Guide

Published by Scalix, Inc.

149 Madison Ave. Suite 302

New York, NY 10016

USA

Copyright © 2008 Scalix, Inc. 
All rights reserved.

Product Version: 11
Document Revision: 3

Notice for Open-Source Software

Copyright (c) 1998-2007 The OpenSSL Project. All rights reserved.

Redistribution and use in source and binary forms, with or without 
modification, are permitted provided that the following conditions are 
met:

1. Redistributions of source code must retain the above copyright 
notice, this list of conditions and the following disclaimer.

 2. Redistributions in binary form must reproduce the above copyright 
notice, this list of conditions and the following disclaimer in the 
documentation and/or other materials provided with the distribution.

 3. All advertising materials mentioning features or use of this software 
must display the following acknowledgment: "This product includes 
software developed by the OpenSSL Project for use in the OpenSSL 
Toolkit. (http://www.openssl.org/)"

4. The names "OpenSSL Toolkit" and "OpenSSL Project" must not be 
used to endorse or promote products derived from this software 
without prior written permission. For written permission, please 
contact openssl-core@openssl.org.

5. Products derived from this software may not be called "OpenSSL" nor 
may "OpenSSL" appear in their names without prior written permission 
of the OpenSSL Project.

6. Redistributions of any form whatsoever must retain the following 
acknowledgment: "This product includes software developed by the 
OpenSSL Project for use in the OpenSSL Toolkit 
(http://www.openssl.org/)"

THIS SOFTWARE IS PROVIDED BY THE OpenSSL PROJECT “AS IS” AND 
ANY EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT 
LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND 
FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT 
SHALL THE OpenSSL PROJECT OR ITS CONTRIBUTORS BE LIABLE FOR 
ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR 
CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, 
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, 
DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED 
AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT 
LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING 
IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF 
THE POSSIBILITY OF SUCH DAMAGE.

This product includes cryptographic software written by Eric Young 
(eay@cryptsoft.com). This product includes software written by Tim 
Hudson (tjh@cryptsoft.com).

Notices 
The information contained in this document is subject 
to change without notice.

Scalix Inc. makes no warranty of any kind with regard 
to this material, including, but not limited to, the 
implied warranties of merchantibility and fitness for a 
particular purpose. Scalix Inc. shall not be liable for 
errors contained herein or for incidental or 
consequential damages in connection with the 
furnishing, performance, or use of this material.

UNIX is a registered trademark of The Open Group.

Linux is a registered trademark of Linus Torvalds.

Microsoft, Windows XP, Windows 2000, Exchange, 
Outlook, and Active Directory are registered 
trademarks or trademarks of Microsoft Corporation.

Groupwise is a registered trademark of Novell, Inc.

Lotus Notes is a registered trademark of Lotus 
Development Corporation.

All other company names, product names, service 
marks, fonts, and logos are trademarks or registered 
trademarks of their respective companies.

Restricted Rights Legend

Use, duplication, or disclosure is subject to restrictions 
as set forth in contract subdivision (c)(1)(ii) of the 
Rights in Technical Data and Computer Software clause 
52.227-FAR14.
2



Scalix Migration Guide | Contents
Contents
Introduction to This Guide . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9

About This Guide . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .9

How to Use This Guide . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .9

Related Documents  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .10

Getting Help . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .10

Introduction to Scalix Migration Tool . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11

About the Scalix Migration Tool . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .11

System Requirements  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .12

Migration Options

Planning the Migration . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 15

Options Introduction  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .15

Decision: To Migrate User Data or Not . . . . . . . . . . . . . . . . . . . . . . . . . . . . .16

Decision: Who Does the Migration?  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .16

Decision: Migration Strategy . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .17

Decision: Mailbox and Directory Provisioning Method . . . . . . . . . . . . . . . . . . .20

Migration Examples  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 23

Company A: 1000 Users, Uniform Environment . . . . . . . . . . . . . . . . . . . . . . .23

Company B: 1800 Users, Mixed Environment  . . . . . . . . . . . . . . . . . . . . . . . .25

Company C: 3000 Users, Mixed Environment  . . . . . . . . . . . . . . . . . . . . . . . .26

Flash Migration from Microsoft Exchange to Scalix

Task 1: Changing the LDAP Setting on the Scalix Server . . . . . . . . . . . . . . 31

Introduction  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .31

Changing the LDAP Server Setting . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .31

Task 2: Creating the Synchronization Agreement  . . . . . . . . . . . . . . . . . . . 33

Adding Administrator Rights to a User Account  . . . . . . . . . . . . . . . . . . . . . . .33

Obtaining Microsoft Exchange Server Values . . . . . . . . . . . . . . . . . . . . . . . . .35

Creating the Synchronization Agreement  . . . . . . . . . . . . . . . . . . . . . . . . . . .35

Task 3: Completing the Initial Directory Synchronization . . . . . . . . . . . . . 39

Introduction  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .39
3



Scalix Migration Guide | Contents
Synchronizing the Directories  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .40

Resetting a Synchronization  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .41

Note About Changing Entries. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .42

Task 4: Migrating Public Folders. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 43

Requirements . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .43

Exporting Public Folders from Microsoft Exchange  . . . . . . . . . . . . . . . . . . . . .43

Importing Public Folders for Scalix . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .46

Task 5: Loading Scalix Mailboxes . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 49

Introduction  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .49

Provisioning a Mailbox  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .50

Verifying the New Mailbox. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .50

Task 6: Reconfiguring Auto-Forward for the New Scalix Mailboxes. . . . . . 51

Introduction  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .51

Removing the Forwarding Address . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .51

Task 7: Configuring Message Forwarding from Exchange to Scalix . . . . . . 53

Introduction  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .53

Adding Alternate Recipient Information for a Single Mailbox . . . . . . . . . . . . . .54

Adding Alternate Recipient Information for Several Mailboxes . . . . . . . . . . . . .55

Task 8: Migrating Mailbox Data  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 59

Requirements . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .59

Introduction  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .59

Extracting Microsoft Exchange Mailbox Data . . . . . . . . . . . . . . . . . . . . . . . . .61

Copying .pst Files into Scalix . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .62

Creating the Target Mailboxes . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .63

Running the Scalix Migration Tool  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .64

Additional Notes  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .65

Task 9: Decommissioning Microsoft Exchange Mailboxes  . . . . . . . . . . . . . 67

Introduction  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .67

Decommissioning a Mailbox  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .67

Decommissioning Multiple Mailboxes  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .68

Phased Migration from Microsoft Exchange to Scalix

How Phased Migration Works. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 73

Introduction  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .73

Mailbox Management During Coexistence . . . . . . . . . . . . . . . . . . . . . . . . . . .80
4



Scalix Migration Guide | Contents
Coexistence in a Single Picture  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .84

Task 1: Activating Auto-Forwarding on Microsoft Exchange  . . . . . . . . . . . 85

Requirements . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .85

Activating Auto-Forwarding on Microsoft Exchange  . . . . . . . . . . . . . . . . . . . .86

Task 2: Preparing the Microsoft Exchange Users Distribution List. . . . . . . 91

Creating the Microsoft Exchange Users Distribution List  . . . . . . . . . . . . . . . . .91

Task 3: Configuring a TNEF route for Microsoft Exchange Users . . . . . . . . 93

Introduction  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .93

Configuring TNEF Routes  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .93

Task 4: Changing the LDAP Setting on the Scalix Server . . . . . . . . . . . . . . 97

Task 5: Creating the Synchronization Agreement  . . . . . . . . . . . . . . . . . . . 99

Task 6: Completing the Initial Directory Synchronization . . . . . . . . . . . . 101

Task 7: Updating Microsoft Exchange and Scalix Directories. . . . . . . . . . 103

Updating Microsoft Exchange and Scalix Directories . . . . . . . . . . . . . . . . . . . 103

Task 8: Updating the Client Directory Access. . . . . . . . . . . . . . . . . . . . . . 105

Updating the Client Directory Access Index . . . . . . . . . . . . . . . . . . . . . . . . . 105

Task 9: Hiding Directory Entries in Scalix Server . . . . . . . . . . . . . . . . . . . 107

Hiding Directory Entries in Scalix . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 107

Task 10: Preparing for Public Folder Migration  . . . . . . . . . . . . . . . . . . . . 109

Introduction  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 109

Determining Which Public Folders to Migrate . . . . . . . . . . . . . . . . . . . . . . . . 110

Resetting Permissions on Public Folders . . . . . . . . . . . . . . . . . . . . . . . . . . . 110

Reorganizing Public Folders and Data . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 110

Creating Public Folders on Scalix Server . . . . . . . . . . . . . . . . . . . . . . . . . . . 112

Checking Your Work. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 113

Task 11: Migrating Public Folders. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 115

Task 12: Enabling Public Folder Forwarding on Scalix Server . . . . . . . . . 117

Introduction  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 117

Setting Up Forwarding . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 118

Activating Forwarding. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 119

Testing Your Work . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 120
5



Scalix Migration Guide | Contents
Task 13: Enabling Public Folder Forwarding on Microsoft Exchange . . . . 121

Introduction  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 121

Requirements . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 122

Activating Folder Forwarding . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 122

Task 14: Effective Distribution List Coexistence  . . . . . . . . . . . . . . . . . . . 125

Introduction  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 125

Creating the Distribution List and Custom Recipient . . . . . . . . . . . . . . . . . . . 125

Task 15: Loading Scalix Mailboxes . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 129

Task 16: Bulk Mailbox Provisioning and Configuration  . . . . . . . . . . . . . . 131

Introduction  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 131

Using Microsoft Exchange Attributes to Provision Scalix Mailboxes . . . . . . . . . 132

Using Scalix Server Attributes to Provision Scalix Mailboxes . . . . . . . . . . . . . 133

Using the Userfile Option to Provision Scalix Mailboxes. . . . . . . . . . . . . . . . . 134

If You are Asked for Passwords . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 134

Task 17: Reconfiguring Auto-Forward for the New Scalix Mailboxes. . . . 135

Task 18: Configuring Message Forwarding from Exchange to Scalix . . . . 137

Task 19: Migrating Mailbox Data  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 139

Task 20: Decommissioning Microsoft Exchange Mailboxes  . . . . . . . . . . . 141

Task 21: Post-Migration and Coexistence Closure Tasks . . . . . . . . . . . . . 143

Achieving Successful Coexistence  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 143

Managing Distribution Lists . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 144

Switching Distribution List Management to Scalix. . . . . . . . . . . . . . . . . . . . . 144

Switching PDL Management After Coexistence. . . . . . . . . . . . . . . . . . . . . . . 147

Continuing Coexistence  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 148

Migrating an IMAP System to Scalix

Completing an IMAP-to-IMAP Mail System Migration  . . . . . . . . . . . . . . . 153

Requirements . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 153

Installing E-Mail Shuttle . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 153

Configuring E-Mail Shuttle. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 154

Loading the Mailboxes on the Scalix Server. . . . . . . . . . . . . . . . . . . . . . . . . 155

Extracting the Mailbox Contents  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 159

Loading the Extracted Data onto Scalix  . . . . . . . . . . . . . . . . . . . . . . . . . . . 159
6



Scalix Migration Guide | Contents
Command Reference

omldapsync Synchronization Command . . . . . . . . . . . . . . . . . . . . . . . . . . 163

Introduction  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 163

Using the omldapsync Command . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 164

Command-Line Options  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 165

Command Examples. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 166
7



Scalix Migration Guide | Contents
8



Introduction to This Guide

About This Guide

This guide outlines how to migrate Microsoft Exchange Server, Post Office Protocol (POP), 
and Internet Message Application Protocol (IMAP) users to the Scalix mail system.

Many of the screen captures in this guide are from Microsoft Exchange Server 5.5. If you are 
using Microsoft Exchange Server 2000, 2003, or 2007, your software can differ from that 
shown here, but the basic steps are the same. The Microsoft Exchange Server product name 
is shortened to Microsoft Exchange or Exchange in the rest of this guide.

How to Use This Guide

This guide uses the following typographical conventions.

Table 1: Conventions Used

Convention Explanation

<Angle Brackets> Values that you need to supply are sometimes shown using angle brackets. For example: 
http://<server_name>/webmail

Numbered and alphabetized 
lists versus bullets Numbered and alphabetized lists denote steps to be followed while bullets provide information.

Buttons
The boldface font indicates a button, a link, a field, or other user interface element to click or 
press as well as a keyboard stroke. For example: Click Finish or type in the Username 
field.

Code
This smaller font indicates code to type or code that is returned as a response. 
For example: ./scalix-installer

Italics Indicates a document or section, a directory path, a file, or the name of a window. For example: 
Open the /var/opt/scalix folder. Or: The Reply screen appears.
9
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Related Documents

Scalix manuals include:

• Scalix Release Notes

• Scalix Installation Guide

• Scalix Migration Guide

• Scalix Setup and Configuration Guide

• Scalix Client Deployment Guide

• Scalix Administration Guide

• Scalix API Guide

In addition, there are online help systems in:

• Scalix Management Console

• Scalix Web Access

• Microsoft Outlook (when enabled for the Scalix connector)

Getting Help

For help with installation, contact technical support at support@scalix.com

For the latest documents, see 
http://www.scalix.com/community/downloads/documentation.php

For documents, a knowledge base, and forums, see 
http://www.scalix.com/community/resources/
10



Introduction to Scalix Migration Tool

This chapter introduces the Scalix migration tool.

Contents
This chapter includes the following information:

• “About the Scalix Migration Tool” on page 11

• “System Requirements” on page 12

About the Scalix Migration Tool

The Scalix Migration Tool (SMT) is a command-line Windows application that moves mailbox 
data from a Microsoft Exchange Server to a Scalix server. It enables the migration of user 
accounts, e-mail, contacts, and calendar data from Microsoft Exchange to Scalix. Using a 
batch script, it moves large numbers of users at once, simplifying and speeding the 
conversion from an existing Microsoft system to Scalix.

Microsoft Outlook rules are not preserved because Microsoft rules are incompatible with 
Scalix.

The Scalix Migration Tool is available for the Scalix Enterprise Edition and Scalix Small 
Business Editions. It is sold separately. Users accounts are migrated as Scalix Premium users.

Process
The tool uses a two-part process by which it:

• Moves users’ mailbox contents from Microsoft Outlook to Scalix

• Corrects any internal addressing inconsistencies to ensure that replies reach their 
intended recipients

The migration tool does not change existing Microsoft Exchange data in any way. All 
procedures are done in “read only” mode and any changes to internal addressing are done 
on the Scalix system.

You can run the first and/or second part of the process; both parts work independently of 
one another.
11
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The basic approach is:

• Install Scalix

• Synchronize the Scalix Lightweight Directory Access Protocol (LDAP) directory with the 
Microsoft Exchange directory. This creates the Microsoft user accounts in the Scalix 
directory so that their mailbox contents have a destination address to copy over to.

• Extract the Microsoft Exchange mailbox contents into a .pst file using ExMerge or 
another method

• Use the Scalix Migration Tool to migrate the contents from the .pst file in Scalix

Errors and Logging
The Scalix Migration Tool is designed to continue with migration even if it encounters errors, 
corrupt messages, or other problems. Rather than halt the migration entirely, the tool 
records a message in the log file.

When you finish any migration procedure, you can check the log files to determine whether 
any important messages did not copy over. The omshowlog command displays event logs.

System Requirements

Scalix is compatible with the following versions of Microsoft Exchange Server, Microsoft 
Outlook, and Scalix. These are the requirements for running the Scalix Migration Tool.

Table 1: Approved Software and Client Components

Components Requirements

Microsoft Exchange Server

• Microsoft Exchange Server 5.5
• Microsoft Exchange Server 2000
• Microsoft Exchange Server 2003
• Microsoft Exchange Server 2007

Microsoft Outlook

• Microsoft Outlook 2000
• Microsoft Outlook XP
• Microsoft Outlook 2003
• Microsoft Outlook 2007

Windows OS
(for client workstations)

• Windows 2000
• Windows XP
All earlier versions of Windows are not supported, regardless of the version of 
Microsoft Outlook you have installed.
Windows Vista is known to work with some limitations but is not officially supported.

Scalix
• Scalix 10.0.0 and above. Scalix 10.0.0 and its associated versions do not support 

internationalization, so English and German are supported but not other languages.
• Scalix 11.0.0 and above

MAPI Connector • Scalix Connect for Microsoft Outlook version 10.0.0 or above
12
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Planning the Migration

This section explains the options for migration.

Contents
This chapter includes the following information:

• “Options Introduction” on page 15

• “Decision: To Migrate User Data or Not” on page 16

• “Decision: Who Does the Migration?” on page 16

• “Decision: Migration Strategy” on page 17

• “Decision: Mailbox and Directory Provisioning Method” on page 20

Options Introduction

There are two principal migration paths:

• Flash migration — For small to moderate numbers users and quantities of data. It trans-
fers all user accounts and data to Scalix in a day or two, for example a weekend. Users 
are told not to use e-mail during the transition. Up to a thousand users can be migrated 
over a weekend.

• Phased migration — For large numbers of users with large quantities of data, moved in 
batches of users. You set up a state of coexistence in which Scalix and legacy mail serv-
ers work in tandem while batches of users are transferred to the new system at strategic 
intervals. The complexity of data is the deciding factor; if you are migrating mail, 
notes, scheduling, and more, phased migration can be the better choice.

The primary concerns are the number of users and how much data each user has.

With a Post Office Protocol (POP) server, the mail is stored on the user’s computer, so you 
can either migrate the basic user data or create new records in Scalix.

With an Internet Message Application Protocol (IMAP) or Mail API (MAPI) based system, if you 
are not transferring user data or your users intend to copy their own data over, a “flash” 
migration can be used. If you have more than 100 users, all of whom expect their files and 
data to be accessible in Scalix, a phased migration is appropriate.
15
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Decision: To Migrate User Data or Not

You must decide whether any or all of the user data needs to be migrated. Data migration is 
the most time-consuming task of the process, whether executed by administrators or end-
users.

The alternative to migrate users to empty mailboxes offers the following benefits:

• Less work to migrate large groups of users to Scalix

• Eliminates the majority of time-consuming efforts by IT staff

• Reduces overall size of Scalix message store

• Streamlines backup efforts initially

• Enables implementation of new e-mail retention and mailbox quota policies

Moving users to Scalix mailboxes without any of their pre-existing data does not mean the 
data is lost or will never be transferred. Most e-mail clients have the ability to keep a locally 
stored copy of the legacy e-mail data.

Decision: Who Does the Migration?

Who actually completes the data migration is another consideration. There are two options:

• Users

• Administrators

Often organizations assume that all data must be migrated by Scalix or network 
administrators, when in fact an end-user-executed local data migration strategy can be 
ideal.

For a POP-based system, because mail has been downloaded to each user’s computer, data 
migration options are limited and are best left to the user.

For an IMAP-based system, client users can copy the data to their local computers, or 
administrators can use a migration utility application to extract/import data from more 
than one user onto the Scalix system.

One approach is to coordinate the data-migration activities of both users and 
administrators. First, provide a time-frame and instructions for all users to execute the 
migration themselves. At the same time, have assistance available for those users who need 
help.

The following table summarizes migration options.
16



Scalix Migration Guide | Planning the Migration
Decision: Migration Strategy

Next, decide on POP, IMAP, proprietary, flash, and/or phased migrations. The next chapter, 
“Migration Examples” on page 23, provides excellent information to understand how 
migration works.

Potential Migration Strategies for POP3 Server Data
Because mail has been downloaded to each user’s computer in a POP-based system, data 
migration options are limited, and are best left to the user. If the same e-mail client that 
connected to the POP-based legacy system is used to connect to Scalix, then all legacy data 
remains fully accessible. If a new e-mail client is used to connect to Scalix, then determine 
if the old client’s data can be exported in a format compatible with the new e-mail client 
(such as a .pst format for Microsoft Outlook clients).

As a minimum, users can leave their legacy e-mail client installed on their computers, 
providing access to the local POP mail archives. They can copy-and-paste the original 
content into any outgoing messages created and sent by means of their new e-mail client.

Table 1: Strategies and their Benefits

No Data Migration Client-Side 
Data Migration

Server-Side 
Data Migration

Process

Data is left in the legacy 
message store and contin-
ues to be accessible 
through the legacy mail 
client.

Data is extracted from the leg-
acy e-mail client in a format 
that can be imported into the 
new e-mail client. Or, the same 
legacy e-mail client is used to 
access the Scalix system.

Using Scalix migration 
tools, user data is trans-
ferred directly from the 
legacy mail store to the 
Scalix mail store.

Advantages

Dramatically streamlines 
overall project efforts.
Clean start with empty 
Scalix mailboxes.

Legacy data is accessible 
within the e-mail client.
If legacy system was POP or 
IMAP, the user retains full reply 
capabilities.
Clean start with empty Scalix 
mailboxes.

All data remains accessi-
ble in the same server-
side folders.
Full reply capabilities.
No end-user involvement.

Disadvantages

Accessing legacy data is 
somewhat cumbersome.
Minimal capabilities with 
legacy mail data (copy 
and paste).

The same procedure must be 
manually executed at every cli-
ent workstation, either by end-
users or administrators.

Requires more work 
behind the scenes by 
administrators.
Dedicated migration work-
station required.
17
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Potential Migration Strategies for IMAP Server Data
IMAP servers offer more migration options. Client users can copy the data to their local 
computers, or administrators can use a migration utility application to extract/import data 
from more than one user onto the Scalix system.

E-mail data is stored directly on the IMAP server, but because most IMAP servers also support 
POP3 access, most e-mail clients allow the user to download the data to a local store. This 
means that, at a minimum, the POP-specific options explained in the previous section are 
applicable to IMAP client users.

The E-Mail Shuttle application can be used for IMAP migration as described in a separate 
chapter.

Possible Migration Strategies for Proprietary Data Formats
Messaging systems, such as Groupwise, Microsoft Exchange, and Lotus Notes, typically 
provide support for IMAP and POP, and they also utilize remote procedure call (RPC)-based 
communication that enables extended capabilities or properties within the message data. 
This means much of the data is in a proprietary format. Although the POP and IMAP 
strategies discussed in the previous sections can be used to extract data from these systems, 
some loss of message fidelity or exclusion of some data types can occur.

These systems usually permit a user to save all server mail data in a local storage file, such 
as a Microsoft Outlook .pst file. If the original e-mail client can connect to Scalix, or a new 
e-mail client is used that can access or import the local storage file, then all the legacy data 
becomes available. But the message headers in the local archive cannot contain standards-
based (RFC 822/823) address definitions because they are proprietary formats. As a result, 
replies to the messages may not route correctly, but forwarded copies are sent correctly.

After extracting data from the legacy mail system, you import that file into Scalix using 
either MAPI or IMAP. An IMAP extraction from the legacy environment and subsequent IMAP 
import into Scalix processes approximately 1 GB of data in one hour.

Flash Migration
A flash migration means that the entire user base is migrated from the legacy system to 
Scalix at one time. There is no interim period where some users use Scalix and others use 
the legacy system. A flash migration is an obvious choice for small organizations or 
organizations for which user-data migration requirements are minimal.

The typical flash migration process is as follows:

• Set up the needed Scalix mailboxes and directory entries

• Transfer the user accounts and their data to Scalix

• Change the mail exchanger (MX) record to the Scalix server
18
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A flash migration is significantly less complex than the phased approach for several reasons:

• There is no need to configure auto-forwards on either server

• There is no need to continually synchronize directories on each server

• The migration process is simpler and can be executed more quickly

While this seems like a logical approach, due to its simplicity, it is often dismissed by 
organizations with a large number of users to migrate. Up to a thousand users can be 
migrated over a weekend.

There are drawbacks to a flash migration:

• There can be too much data to migrate over a weekend, for example

• There can be a spike in end-user requests for assistance if they are unfamiliar with the 
new system

You can minimize these drawbacks:

• Spend time in advance to create instructions for users so that they do not contact you

• Maximize Domain Name System (DNS) use. You can inform users that the switch to the 
new mail system is scheduled for 6:00 pm on a Friday. Switching MX records or C-names 
to the new systems can occur at 6:00 pm, but all mailboxes are set up in advance. Users 
have full mail capabilities and any new mail that arrives after 6:00 pm from the Scalix 
environment. Legacy mail becomes available later during the weekend, for example 
Monday morning.

• Optional: Employ an end-user-executed data migration strategy for either all or a signif-
icant portion of the users. This minimizes the amount of server-side data to migrate.

• Retain user access to the legacy data on the legacy server until the data is fully 
migrated

Phased Migration
A phased migration is when a partial number of user accounts are migrated at a time. The 
two messaging environments must coexist until the transfer is complete. Coexistence 
requires careful setup procedures, but can be transparent to system users who have no idea 
that their mail and data are moving from one system to another.

The typical phased migration has the following process:

• Set up message routing:

• Configure routing between Scalix and the legacy system

• Make the DNS changes, adding any needed MX records

• Synchronize and provision the Scalix system:

• Load all mailboxes and/or directory entries

• Configure the forwarding mechanism on mailboxes (for coexistence)

• Set up coexistence processes on the legacy system:

• Load custom recipient/contact entries

• Transfer the first subgroup (users and their data):
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• Migrate legacy data to the local store, then to the Scalix message store

• Activate just-migrated mailboxes on Scalix

• Configure migrated mailbox auto-forwarding on the legacy system

• Repeat the previous step at strategic intervals, until all groups of users and their data 
are transferred to Scalix

• Make the MX record changes, redirecting inbound Internet mail to Scalix

• Leave the legacy server in place for a period of time, and eventually decommission it

Decision: Mailbox and Directory Provisioning 
Method

Having chosen the data to be migrated and the migration method, decide how to set up the 
needed directory entries and mailboxes on the Scalix server. There are two ways to set up 
(or “provision”) these items, before transferring users and data from the legacy mail 
system:

• The Scalix Management Console is adequate but inefficient because it restricts your 
work to only one directory entry/mailbox at a time. This is unsuitable to load hundreds 
of users in as short a time as possible.

• Scalix command-line tools can be utilized. Each offers multiple options that can be used 
to bulk-load hundreds or thousands of names into a Scalix server.

In most cases you simply need to make sure the appropriate mailboxes or directory entries 
are provided, either through ready-formatted text files or through some means of accessing 
the records on the legacy mail system.

The commands for mailbox and directory provisioning (omldapsync, omaddent, and omaddu) 
are outlined in the following sections.

Synchronization Command omldapsync
Any legacy messaging environment that provides Lightweight Directory Access Protocol 
(LDAP) support can take advantage of the omldapsync tool. This tool not only assists in 
provisioning Scalix mailboxes with auto-forwards, but it also provides the ability to load 
directory objects in the legacy environment, such as Contacts or Custom Recipients in 
Microsoft Exchange environments.

The step-by-step use of omldapsync is detailed at the appropriate place in this guide.

Commands omaddent and omaddu
The omaddent and omaddu commands are for adding directory entries and users to Scalix. 
These can be integrated into scripts and customized for bulk data loading. Additionally the 
ability to load mailboxes with auto-forwards is provided by means of the sxaa utility.
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Add Directory Entries With omaddent
In most cases, mail server directory entries (as contrasted with mailbox entries) provide an 
easy way for the users to send mail to destinations external to Scalix (Internet recipients). 
You create a text file of the current directory entries as follows:

CN=Smith, John/OU1=Internet/IA=john.smith@company.com

CN=Jones, Fred (Pager)/OU1=Internet/IA=216.2725566@mobile.att.net

CN=Catering Orders/OU1=Internet/IA=Creighton.Catering@sbcglobal.net

Then import the file into Scalix:

omaddent -f <filename.txt>

This allows Scalix users to select or search for “Smith, John”, “Jones, Fred”, and “Catering 
Orders” in the Scalix address books, as well as for messages to route to the destination 
Internet address as specified in the input file (filename.txt).

Add Users Accounts With omaddu
In preparation for migrating user data, you must create mailboxes on your Scalix system 
with the same parameters as those on the legacy system. New mailboxes on Scalix can be 
efficiently provisioned by means of omaddu, utilizing the bulk option of the omaddu 
command and using the name of an input file that contains most if not all of the necessary 
information for a user.

A simple way to do this is to take advantage of the automatic generators for the display 
name, Internet addresses, and authentication ID, thus simplifying the contents of the input 
file to be passed to omaddu.

To prepare your Scalix system for bulk mailbox provisioning with omaddu and Scalix 
Management Console

1 Log in to your Scalix server as the root user.

2 Log in to Scalix Management Console.

3 Click Settings.

4 Set the appropriate mail address settings for generating the following:

• Internet address

• Display Name Rule, which determines how the users names are displayed in the sys-
tem address book. It is the “friendly” name, not the e-mail address. An example is 
First Last

• Authentication ID Rule, which is the name or identification used to log in to the sys-
tem. An example is First.Last

The Default Domain is appended to the Authentication ID Rule to form the entire 
Authentication ID for each Scalix account.

Once this has been established, test the provisioning process by creating a single mailbox on 
Scalix through omaddu. Following this, use omshowu to verify all values were correctly 
transferred to Scalix.

omaddu -n "Test User/mailnode" -p pass 

Verify that the Internet address and authentication ID are created correctly and the 
common name (cn=) value is what is wanted for the system address book.

To load all users, create a simple text file with their names. The format of the text file looks 
like:
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@ Firstname Lastname 

@ Firstname Lastname 

@ Firstname M. Lastname 

@ Firstname Lastname Jr. 

To verify the transfer of values

1 Run this command:

omshowu -n "Test User/mailnode" 

To format the text file

1 Enter a last name (family name), up to 40 characters. This is called Surname (or “S”) in 
the X.400 syntax.

2 Enter an optional first name (given name, “G”), up to 16 characters.

3 Add any optional initials (for example “K”), up to five. Each initial must be followed by 
a period (.) when you define or use the name. They are automatically capitalized.

4 Enter an optional suffix (generation qualifier, “Q”), such as Jr, up to three characters.

5 Next, the file (named dirload.txt in the example here) can be used to bulk load all users 
with the following command:

omaddu -bulk -p pass mailnode dirload.txt 

The -e switch can also be passed in the same omaddu command to set each mailbox to the 
“pre-expired” state and force users to replace the existing password with a new password 
when they first log in to the Scalix server.

If you want deeper control, you can specify exactly what you want for each user in the input 
file and it overrides the settings in Scalix Management Console. For example, in the input 
file shown as follows, for the first three users the authentication ID is specified, followed by 
the user’s name, then the display name, then primary Internet address (with friendly name) 
and in the case of “Ed Ott” even a second Internet address. Notice however the mailbox 
“Room 22” has everything but the user name automatically generated.

jdoe@SRV.LOCAL Joe Doe/CN=Doe, Joe/IA="Joe Doe" <joe.doe@corp.com>

eott@SRV.LOCAL Ed Ott/CN=Ott, Ed/IA="Ott, Ed" 

ed.ott@corp.com=eott@corp.com

tfjones@SRV.LOCAL Ty F. Jones/CN=Jones, Ty F/IA="Jones, Ty F" 

<ty.f.jones@corp.com>

@ Room 22
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Migration Examples

This chapter offers three case studies to help you understand how migration works.

Contents
This chapter includes the following information:

• “Company A: 1000 Users, Uniform Environment” on page 23

• “Company B: 1800 Users, Mixed Environment” on page 25

• “Company C: 3000 Users, Mixed Environment” on page 26

The examples illustrate basic strategies for mail migration used by actual Scalix customers.

Company A: 1000 Users, Uniform Environment

Pre-Migration Environment — 1000 users on Microsoft Exchange 5.5, all using Microsoft 
Outlook (MAPI)

Post-Migration Environment — 1000 users on Scalix 9.2, all using Microsoft Outlook (MAPI)

Table 1: Company With 1000 Users

Decision Details Results

Architecture Single server (dual P4, 4 GB RAM, RAID 5, 
400 GB, SCSI)

Provided approximately 300+ MB of storage 
per mailbox, plus room for LVM snapshots, 
suitable CPU, disk and memory for Microsoft 
Outlook (MAPI) or Scalix Web Access with 
excellent performance.

Migration Strategy

Flash migration, no coexistence required. An 
initial load of a few mailboxes and testing 
occurred, then all mailboxes were loaded into 
Scalix. MX records were then redirected to 
Scalix server.

Flash migration dramatically shortened the 
overall project length. Post-migration results 
included an initial spike in help desk requests 
due to minor end-user issues, mostly educa-
tional in nature. No directory synchronization 
was required.
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Notes
• The installation of Scalix Connect and subsequent generation of Scalix profiles was exe-

cuted by users on Monday morning as a first step, followed by the entry of their user-
name and password. This took about two minutes per user, with a few taking up to five 
minutes. Once the users successfully logged in to their Scalix mailboxes, all mail data 
was available.

• Instructions for using Scalix Web Access were provided for users who were not able to 
access Microsoft Outlook through Scalix Connect. The IT team later helped each of these 
users attain the files to install Scalix Connect and generate the Scalix profile.

• By the close of business on Monday, approximately 90 help-desk queries were logged:

• Approximately 65 were resolved in five minutes or less

• 40 queries were attributed to users not reading the instructions for installing Scalix 
Connect

• 25 queries were from users entering invalid usernames or passwords

• 12 were pre-scheduled incidents for remote users who required extra assistance

• The remaining queries were miscellaneous issues, such as not understanding how to 
link .pst files, enabling off-line synchronization

• On Tuesday there were 16 help-desk queries relating to e-mail

Data Migration Strategy

Deployed four migration workstations to 
accomplish full transfer over one weekend. 
Pace — 125 mailboxes per day, per worksta-
tion in a 12 hour period.
Users installed Scalix Connect on Monday 
morning.

All users accessed legacy data (mail, con-
tacts, calendar, and so on) from their Scalix 
mailbox on Monday and had full reply capabil-
ity. Required an intensive weekend for the IT 
staff.

Provisioning Method

Used omaddu with the bulk option, and preset 
automatic generators in the Scalix Manage-
ment Console for display name and Internet 
addresses.

Extremely fast way to create all mailboxes on 
Scalix, and automatically have standards for 
the display name and Internet addresses. 
Required a simple flat file created in advance 
based on Microsoft Exchange users.

Table 1: Company With 1000 Users

Decision Details Results
24



Scalix Migration Guide | Migration Examples
Company B: 1800 Users, Mixed Environment

Pre-Migration Environment — 1800 users on IMAP server with various IMAP clients

Post-Migration Environment — 1600 on Scalix Web Access, 200 on Microsoft Outlook (MAPI)

Notes
• This organization declared an e-mail outage from 9:00 pm Friday evening until 6:00 am 

Monday morning, and let mail queue on the perimeter mail relay during that time. This 
provided an effective back out strategy. If the migration process had issues during the 
weekend, they had the option to let the mail route to the legacy server and try again 
another weekend and users would not lose any mail. If all was successful then the 
queued mail would be routed to the new Scalix server on Sunday night.

• No client software deployment was necessary for 1600 of the 1800 users who used Scalix 
Web Access; the other 200 on Microsoft Outlook (MAPI) were provided the instructions 
for installing Scalix Connect, creating the profile, and accessing their mailbox.

• All Scalix users authenticated against a corporate LDAP server through Scalix Web Access 
and Microsoft Outlook. Authentication IDs were pre-loaded on all mailboxes through 
bulk load process and PAM-based authentication configuration completed with the help 
of Scalix-ready documentation.

Table 2: Company With 1800 Users

Decision Details Results

Architecture Single server (dual P4, 6 GB RAM, RAID 1+0, 
250 GB, SCSI)

Provided approximately 50+ MB of storage per 
mailbox for Scalix Web Access users (mailbox 
limits enforced), 500+MB for Microsoft Outlook 
users, and room for LVM snapshots, suitable 
CPU, disk and memory for Scalix Web Access 
with snappy performance. Peak Scalix Web 
Access logins were less than 300 in a 30-
minute time period.

Migration Strategy

Flash migration, no coexistence required. All 
mailboxes were loaded into Scalix; inbound 
MX records were then modified at 9:00 pm on 
Friday evening.

Lack of coexistence dramatically shortened 
the overall project length. IT staffers saw an 
initial spike in help desk requests due to minor 
end-user issues, mostly educational in nature.

Data Migration Strategy

Used four migration workstations to migrate 
approximately 250 mailboxes per day, per 
workstation in a 12-hour period. Completed 
the entire migration over the weekend.
200 users installed Scalix Connect on Monday 
morning.

All users accessed their legacy data (mail, 
contacts) from their new Scalix mailboxes on 
Monday with full reply capability. Required an 
intensive weekend for the IT staff.

Provisioning Method
Used omaddu with the bulk option, but 
because no standard Internet address were 
used, specified all values in the bulk input file.

Extremely fast way to create all mailboxes on 
Scalix while accounting for lack of standard 
Internet addresses, but apply standards to dis-
play names.
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Company C: 3000 Users, Mixed Environment

Pre-Migration Environment — 3000 users on a POP server with various POP and IMAP-
supporting clients

Post-Migration Environment — 2800 users on Scalix Web Access, 200 on Microsoft Outlook 
(MAPI)

Notes
• Outbound SMTP server setting in each legacy POP client pointed to a C-Name DNS entry 

that was then redirected to the Scalix server. This provided the users an option of 
accessing their legacy mail by means of their old POP client and simply replying.

• Many of executive-level team required their legacy mail data migrated to their Scalix 
mailbox. For these users, the Netscape client used for POP access to the legacy server 
was configured with an additional IMAP service that connected to the Scalix server. Once 
connected, this data was simply dragged and dropped into the server-side Scalix folders.

• The /etc/opt/scalix/webmail/partner.xml file was configured to provide LDAP searches 
against the legacy POP server in addition to Scalix system address book and each user’s 
local contacts. Because addressing in Scalix Web Access is primarily performed through 
the Search Names functionality (which then uses the LDAP settings in the partner.xml 
file), this enables full address book capabilities for all Scalix Web Access users but with 

Table 3: Company With 3000 Users

Decision Details Results

Architecture Dual-server (dual P4, 6 GB RAM, SCSI, RAID 
5, 1 TB)

Provided approximately 250+ MB of storage 
per mailbox for all users and room for LVM 
snapshots, suitable CPU, disk and memory for 
Scalix Web Access with snappy performance. 
Peak Scalix Web Access logins were less than 
300 in a 30-minute time period.

Migration Strategy

Phased migration, three phases. Loaded 200 
mailboxes on the first Scalix server in phase 1, 
then 1300 three weeks later. Loaded the final 
1500 on the second Scalix server four weeks 
later.

Enabled large groups of users to be migrated, 
but not too many that it overwhelmed the sup-
port group. Did have to script the loading of 
forwards for the first 1500 mailboxes during 
coexistence (Phase 1 and 2).

Data Migration Strategy
Legacy data was left locally in the legacy POP 
store for most users; some data was migrated 
using a client-to-server method.

End-users did not have legacy mail data inside 
the Scalix mailbox, but had access through the 
legacy client. Administrators benefited from a 
fresh start with empty mailboxes.

Provisioning Method

Used omaddu with the bulk option and the 
preset automatic generators in the Scalix 
Management Console for display name and 
Internet addresses. Also used the Scalix Man-
agement Console to manually add extra Inter-
net addresses for some users.

Fast way to create all mailboxes on Scalix, 
and automatically have standards for the dis-
play name and Internet addresses applied, 
and account for users who had been receiving 
mail on non-standard Internet addresses.
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only a partial amount of the mailbox actually loaded on Scalix. Even though there was a 
coexistence period, no forwards or extra directory entries were required.
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29



Scalix Migration Guide | 
30



Task 1: Changing the LDAP Setting on
the Scalix Server

This chapter covers changing a setting on the Lightweight Directory Access Protocol (LDAP) 
server for a high numbers of users.

Contents
This chapter includes the following information:

• “Introduction” on page 31

• “Changing the LDAP Server Setting” on page 31

Introduction

If you are migrating more than 1,000 user mailboxes from Microsoft Exchange to Scalix, you 
must modify an LDAP setting on the Scalix server to increase the default capacity.

Changing the LDAP Server Setting

You modify the slapd.conf file to configure LDAP for the migration.

To fine-tune LDAP on the Scalix server

1 Log in to the Scalix server as root.

2 Use an editor to open this configuration file:

/var/opt/scalix/<nn>/s/sys/slapd.conf

where nn varies with Scalix installation.

3 Look for and change the size limit values, which are shown in bold text in the following 
example of an sldap.conf file.

Increase the size limit values enough to extract all entries in the Microsoft Exchange 
directory to the Scalix server. For example, if the migrating mailboxes number 1,800, 
then replace “1000” with “2000” (to allow for increases during the phased migration).

database    om

suffix      "o=MyContacts"
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flatSuffix    "o=MyContacts"

directory     _MYCONTACTS_

sizelimit     1000

timelimit     100

useDit        false

engines       10

#             

database      om

suffix        "o=Scalix"

flatSuffix    "o=Scalix"

#directory    SYSTEM

sizelimit     1000

timelimit     15

useDit        false

engines       10

#             

database      om

suffix        ""

flatSuffix    "o=Scalix"

#directory    SYSTEM

sizelimit     1000

timelimit     15

useDit        false

engines       10

4 Save the slapd.conf file.

5 To restart the LDAP service, enter the following command:

omoff -a slapd

6 Wait approximately one minute and enter:

omon -a slapd

The reconfigured LDAP service is now in effect.
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Task 2: Creating the
Synchronization Agreement

This chapter covers the synchronization agreement needed to create/provision users on the 
Scalix system, based on user records from the Microsoft Exchange server.

Contents
This chapter includes the following information:

• “Adding Administrator Rights to a User Account” on page 33

• “Obtaining Microsoft Exchange Server Values” on page 35

• “Creating the Synchronization Agreement” on page 35

Adding Administrator Rights to a User Account

You pre-configure the “Service Account Admin” rights/permissions for the Microsoft 
Exchange Administrator account that you want to use for coexistence with Scalix. You need 
the domain name or Internet protocol (IP) address of the Microsoft Exchange server to do 
this.

To add Service Account Admin rights to an existing user account

1 Start Microsoft Exchange Administrator.

2 Click the relevant mail site name.

3 Click File > Properties. A properties window opens.
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4 In the properties window, click the Permissions tab.

5 Click Add. The Add Users and Groups window appears.

6 Open the List Names From menu and choose the relevant server name.

7 In the Name list, select the relevant administrator or administrator group name.

8 Click Add. The selected name appears in the Add Names field.

9 Click OK to close the Add Users and Groups window.

10 If a permissions/domains confirmation window appears, click OK to close it. The prop-
erties window reappears.

11 From the Roles drop-down list, choose Service Account Admin.

12 Click Apply, then click OK to save this new permission state and close the properties 
window.
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Obtaining Microsoft Exchange Server Values

Before starting the agreement, you obtain the Microsoft Exchange values for the 
synchronization command (omldapsync) “a” attribute from the Microsoft Exchange server.

To obtain required values from the Microsoft Exchange server

1 Open the Microsoft Exchange Administrator application.

2 Select the site container that you are synchronizing.

3 Double-click any of the current user accounts. A properties window opens.

4 In the properties window, click the E-mail Addresses tab.

5 Note the following X.400 values:

C= country

P= organization

O= your_site

Write down this information and have it ready for the following procedure.

Creating the Synchronization Agreement

Create the agreement to synchronize the Microsoft Exchange server with the Scalix server. 
You need the domain name or Internet protocol (IP) address of the Microsoft Exchange 
server to do this.

To configure a synchronization agreement for the Exchange-to-Scalix migration

1 Log in to Scalix server as root.

2 To execute omldapsync in interactive mode, enter this command:

omldapsync -i <syncid>

where syncid is a unique name for your Exchange-Scalix migration synchronization 
agreement. Make the name no more than six alphanumeric characters in length. An 
example is Ex2Sx.

3 In the omldapsync menu that appears

0. Display this menu

1. Configure the LDAP dir sync settings

2. Force a complete (re)load of the directory

...

enter the number 1 at the prompt.

The omldapsync command determines that this is the initial directory synchronization 
and creates the subfolder for the synchronization agreement along with a sync.cfg file 
that is placed in the folder.

4 The response asks you to identify the type of Microsoft Exchange server:

INPUT: Select sync agreement type to create (00):

If you are synchronizing with Microsoft Exchange 5.5, enter 00 (two zeros).
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If you are synchronizing with Microsoft Exchange 2000, 2003, or 2007, enter “11” 
(eleven).

5 The first of a series of interactive configuration prompts now appears:

INPUT: value for SCALIXHIDEUSERENTRY (scalixHideUserEntry):

INPUT: value for SCALIXMAILBOXCLASS (scalixMailboxClass):

INPUT: value for SCALIXLIMITMAILBOXSIZE (scalixLimitMailboxSize):

INPUT: value for SCALIXLIMITOUTBOUNDMAIL (scalixLimitOutboundMail):

INPUT: value for SCALIXLIMITINBOUNDMAIL (scalixLimitInboundMail):

INPUT: value for SCALIXLIMITNOTIFYUSER (scalixLimitNotifyUser):

INPUT: value for EX_SCALIX_MAILBOX (scalixScalixObject):

INPUT: value for EX_SCALIX_MAILNODE (scalixMailnode):

INPUT: value for EX_SCALIX_MSGLANG (scalixServerLanguage):

INPUT: value for EX_SCALIX_ADMIN (scalixAdministrator):

INPUT: value for EX_SCALIX_MBOXADMIN (scalixMailboxAdministrator):

If prompted, press Enter to accept default values.

6 You are prompted to edit the configuration file:

Edit config file now y/n (n)

Enter y.

7 You are prompted if you want to use the VI editor:

Use vi to edit y/n (n) 

Enter n.

8 You are prompted about the Java home directory:

JAVA_HOME[/usr/java/j2sdk1.4.2_02]:

Press Enter to accept the default.

9 You are prompted to identify the Microsoft Exchange server:

EX_HOST[]:

Enter the fully qualified domain name or IP address of the Microsoft Exchange server at 
the EX_HOST prompt. Use this format for the entry:

server.domain.ext

The EX_ variable indicates an export from the Microsoft Exchange server.

10 You are prompted to identify the Microsoft Exchange Administrator account to use:

EX_LOGON[cn=Export Admin,cn=user,dc=your_org,dc=com]:

Enter the Microsoft Exchange Administrator account user name.

11 You are prompted for the password:

EX_PASS[]:

Note If you are familiar with the synchronization agreement process and the VI editor, you can enter y 
at the prompt if future configuration changes are needed. For the initial configuration, enter n so 
that the omldapsync command can step you through configuration of the sync.cfg file.
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Enter the Microsoft Exchange Administrator password.

This password automates the entire migration process. If you do not enter the password, 
omldapsync prompts you for a password every time you run the command. If security is 
a question, the password is saved in the sync.cfg file and is protected by the security 
policies configured for the Linux host system on which Scalix Server operates.

12 When omldapsync displays the following information:

IM_LOGON[Import Admin]:

Enter the Scalix server name, for example scalix1.yourcompany.com

13 Accept the default path shown:

IM_CAA_URL[http://local_server.your_domain.com:8080/caa/]:

by pressing Enter.

14 Enter a path to store the key:

IM_CAA_KEYSTORE[]:

for example use the path shown of /var/opt/scalix/ldapsync/keystore 

15 Enter your Scalix administrator user account and domain:

IM_CAA_NAME[user_name@your_domain.com]:

for example sxadmin@yourcompany.com

16 Enter the password for that account at the prompt:

IM_CAA_PASS[]:

17 When omldapsync displays the following information:

EX_BASE1[cn=users,dc=your_org,dc=com]:

enter the Microsoft Exchange Global Address List (GAL) container.

You can specify up to three containers using the subsequent prompts (EX_BASE2 and 
EX_BASE3) when you have more than one container. If not, EX_BASE is sufficient.

18 When omldapsync displays the following information:

IM_OMADDRESS[/internet,tnef]:

enter the route you want to use throughout the duration of migration coexistence. When 
typing the route name, type only the name (not the “tnef” text) and be sure to enter a 
“/” preceding the name. For example:

/route_name

19 When omldapsync displays the following information:

INPUT: Compare old config with new y/n (n): 

enter y at the prompt.

20 When omldapsync displays the following prompt:

INPUT: Replace old config with new y/n (?): 

enter y at the prompt.
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21 When omldapsync displays the following information:

INPUT: Attempt to test data extraction now y/n (n):

enter y at the prompt. Output similar to the following appears, where the agreement is 
named “sa1”:

INFO: test searching from bamex55.bamail.net ... 

INFO: search base is cn=Recipients,ou=BAMUS,o=bamail

INFO: ... test searched OK. 

INFO: test searching from localhost ... 

INFO: search base is o=Scalix 

INFO: ... test searched OK. 

STATUS: Configuration of sa1 completed ########

This completes the agreement setup process.

Resolving Error Messages
If any WARNING or ERROR messages appear during this procedure, verify the synchronization 
agreement.

To verify the agreement

1 While logged in to Scalix, enter this command:

omldapsync -i <syncid>

where syncid with the name of the Microsoft Exchange-Scalix migration synchronization 
agreement that you created.

2 When the omldapsync menu appears, enter 1 and press Enter.

The synchronization agreement is now complete and ready for use.
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Task 3: Completing the Initial
Directory Synchronization

This chapter covers how to run the initial directory synchronization.

Contents
• “Introduction” on page 39

• “Synchronizing the Directories” on page 40

• “Resetting a Synchronization” on page 41

• “Note About Changing Entries” on page 42

Introduction

After you complete the synchronization agreement, you can synchronize the directories on 
the Microsoft Exchange and Scalix servers. As with the agreement procedure, you execute 
the omldapsync command and enter the synchronization ID.

The initial directory synchronization process does the following:

• Exports all entries in the Microsoft Exchange LDAP container specified in the synchroni-
zation ID file

• Adds all entries to the Scalix server directory

• Converts Distribution Lists into Public Distribution Lists in Scalix

• Imports all entries from Scalix

• Adds all entries to the specified Microsoft Exchange container
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Synchronizing the Directories

Synchronize the Scalix and Microsoft Exchange directories so that the content is the same.

To synchronize the directories for the first time

1 Log in to the Scalix server.

2 To execute omldapsync in interactive mode, enter this command:

omldapsync -i <syncid>

where syncid is the name of your Microsoft Exchange-Scalix migration synchronization 
agreement that you created.

3 When the omldapsync menu appears:

0. Display this menu

1. Configure the LDAP dir sync settings

2. Force a complete (re)load of the directory

3. Update the directory after some changes

...

enter the number 2. This prompts omldapsync to synchronize the directory for the first 
time.

When you see a message similar to “export sa1 completed”, the synchronization is com-
plete and was successful.

If any error messages appear, follow the procedure in the next section to resolve the sit-
uation.

Managing Errors
It is not uncommon to encounter minor errors during the directory synchronization process. 
The omldapsync command notifies you of errors that occur during the synchronization of 
directories and provides an option to manage errors so that synchronization continues 
uninterrupted.

The following procedure describes a scenario in which the Microsoft Exchange Distribution 
List representing the Scalix server users was added and an error occurs when Scalix server 
attempts to export the Distribution List.

To manage errors

1 Execute omldapsync by entering the following command:

omldapsync -i <syncid>

2 When the menu appears, enter 3.

The following information displays:

STATUS: LDAP dir sync import sync01 started ###############

...

INFO: ... 0 entries to delete

INFO: ... 2 entries to add

INFO: ... 1 entries to modify

STATUS: delete old entries from flipper.bamail.net ...
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INFO: ... 0 entries deleted

STATUS: add new entries to doclab.bamail.net ...

adding new entry cn=Scalix UsersDL,o=Scalix

ldap_add: Already exists

adding new entry cn=sName,o=Scalix

The ldap_add process notifies you that an entry already exists (this is where the Distri-
bution List originated).

3 If you intentionally added the Exchange Distribution List knowing that omldapsync gen-
erates errors in this situation, you can “accept” the error by entering the following at 
the omldapsync prompt:

omldapsync -i <syncid>

4 When the omldapsync menu appears, enter 4 to accept the error and update the direc-
tory.

The directory synchronization is now complete.

Resetting a Synchronization

There are scenarios in which you want to reset Scalix after an initial synchronization from 
Microsoft Exchange is completed or failed.

To reset a synchronization

1 Create a file with the name of all of the mailboxes that were to have been synchronized 
in the first attempt. To do so, run this command:

omshowu –m all > allmailboxes.out

2 Use your preferred editor and open the allmailboxes.out file that is in your home folder.

3 Delete the lines that contain the two system accounts: sxadmin and sxqueryadmin 
because you do not want to delete them along with the others.
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4 Purge the other mailboxes by running this command:

omdelu –f allmailboxes.out

5 To create a new list of directory entries that you want to migrate to mailboxes, run this 
command:

omsearch –e “cn=*” –m cn > alldir.out

6 Use your editor to open this newly created file and remove the following entries:

sxadmin, sxqueryadmin, ScalixAdmins, ScalixUserAdmins, ScalixGroupAd-

mins, ScalixUserAttribtesAdmins.

These mailboxes either already exist (sxadmin and sxqueryadmin) or are mailboxes rep-
resenting groups.

7 Run the original ommigu command with this new input file, as shown here:

ommigu –userfile alldir.out –m mailnode –p password –expire > 

ommigu.stdout 2> ommigu.stderr

8 Run the ommigu command, including the –raf option:

ommigu –userfile alldir.out –raf

The synchronization now runs without errors.

Note About Changing Entries

The omldapsync command does not report errors. Subsequent updates do not attempt to 
add a missing entry. However, there are instances that require you to perform more labor-
intensive tasks such as manually modifying a directory entry on the Microsoft Exchange or 
Scalix server.

Scalix recommends that you change the target side of the directory synchronization to 
resolve conflicts. For example, if you are trying to synchronize a new Microsoft Exchange 
user named “John Doe”, and the remote recipient with the same name already exists in 
Scalix, change the remote recipient entry to “John Doe1” (or something similar) and select 
option 3 (Update the directory after some changes) in the omldapsync menu. omldapsync 
reports no errors when successful. If errors do occur after you successfully add the “John 
Doe1” entry in the Scalix server directory, select option 4 (Accept previous error and update 
directory) in the omldapsync menu to ignore the error.

Alert Do not run the command in step 8 if the command run in step 7 results in errors.
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Task 4: Migrating Public Folders

This chapter covers the procedure for migrating public folders from Microsoft Exchange to 
Scalix.

Contents
This chapter includes the following information:

• “Requirements” on page 43

• “Exporting Public Folders from Microsoft Exchange” on page 43

• “Importing Public Folders for Scalix” on page 46

Requirements

You export public folders from Microsoft Exchange, then import them. If you have not 
already done so, create the two e-mail user profiles in the Windows Mail control panel that 
Microsoft Outlook refers to in this process:

• Scalix

• Microsoft Exchange

Exporting Public Folders from Microsoft Exchange

When migrating public folders to Scalix, you start by exporting them from Microsoft 
Exchange.

To export public folders from Microsoft Exchange

1 Using a “Microsoft Exchange” profile, start the Microsoft Outlook client. This allows you 
to connect to the Microsoft Exchange server as a public folder owner.

2 Choose File > Import/Export. A wizard appears.
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3 Select Export to a File, and click Next. The Export to a File screen appears.

4 Select Personal Folder File (.pst), and click Next. The Export Personal Folders 
screen appears.

5 Navigate to the folder into which you copied the Microsoft Exchange public folders that 
you want to migrate (“Clean and migrate”).

6 Check the Include Subfolders check box.

7 Click Next. The Export Personal Folders screen appears.
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8  Enter a name for the file (in the format “file_name.pst”) and specify a folder location 
in which to save the file. Write down the file name and location pathway for future ref-
erence.

9 Click Finish. A window appears.

10 If you have concerns about the vulnerability of your public folder data, enter a password 
for the .pst file.

11 Click OK to proceed.

12 A series of export status windows appears, representing the contents of each folder. 
Upon completion, you can import the .pst file to the Scalix server (next section).
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Importing Public Folders for Scalix

Now import the folders.

To import the just-exported .pst files for Scalix

1 Using a Scalix profile, start Microsoft Outlook. This allows you to log in as a public folder 
owner on the Scalix server.

2 In the folder list, select Public Folders.

3 Choose File > Import/Export. A wizard appears.

4 Select Import from Another Program or File, and click Next. The Import a File 
screen appears.
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5 Select Personal Folder File (.pst), and click Next. The Import Personal Folders 
screen appears.

6 Click Browse, and locate and select the file that you created previously.

7 Enable the Replace Duplicates with Items Imported option.

8 Click Next. The Import Personal Folders screen appears.

9 Use the explorer view to locate and select the top-level folder (“clean and migrate”) 
that contains the public folder(s) you want to migrate.

10 Enable the check box by Include subfolders.

11 Enable the Import items into the same folder option.

12 Select Mailbox - username from the drop-down list.

13 Click Finish.
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Task 5: Loading Scalix Mailboxes

This chapter explains how to provision Scalix mailboxes.

Contents
This chapter includes the following information:

• “Introduction” on page 49

• “Provisioning a Mailbox” on page 50

• “Verifying the New Mailbox” on page 50

Introduction

The migration process (outside of coexistence) requires that you convert Microsoft Exchange 
directory entries to Scalix server mailboxes. The principal tool is a Scalix command, 
ommigu. This command modifies Scalix server directory entries that represent Microsoft 
Exchange users. After omldapsync loads a Scalix server directory with Microsoft Exchange 
directory objects (such as mailboxes, custom recipients, distribution lists), the next step is 
to modify the objects so that they become mailboxes, ready for use or for data importation.

You must apply ommigu to all Scalix directory objects that are to become local Scalix 
mailboxes. For example, if an organization has 10,000 Microsoft Exchange mailboxes 
planned for migration onto two Scalix servers (5,000 users on each), you can provision all 
5,000 users at this stage of the migration process. The unprovisioned 5,000 users remain on 
the other Scalix server as directory entries that (respectively) reference (using a SMTP 
address) the original Microsoft Exchange mailbox (similar to the period after the initial 
synchronization occurred using omldapsync).

The ommigu command converts each directory object to a full Scalix server mailbox while 
excluding it from the omldapsync process. ommigu also creates auto-forwarding information 
in the mailbox so that mail addressed to a Scalix server mailbox routes back to the 
respective Microsoft Exchange mailbox (using an SMTP address).
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Provisioning a Mailbox

To provision a single directory entry as a mailbox (to validate the process)

1 Log in to Scalix.

2 Open a terminal window and enter the following:

ommigu -n “Exchange Display Name” -m “Scalix mailnode of the user” -G 

The command arguments include the following:

• “Exchange Display Name” is the equivalent of the Scalix server “Common Name” 
attribute

• –G generates a random password for the mailbox

• –p <password> lets you specify a specific password

• -expire forces users to specify a new account password the first time they log in to 
Scalix server

Here are sample mailbox-provisioning commands:

ommigu –n “Forest Stevens” –m “xyzcorp,usa” –G

ommigu –n “Dave Johnson” –m “xyzcorp.usa” –p 123456 –e

3 Use these two commands to assess the results in Scalix.

omsearch -e cn=*

which lists the new mailbox by Common Name.

omshowiam -m -ca=“exchange_display_name”

which lists the attributes for the user.

Verifying the New Mailbox

To see if the new mailbox appears in Microsoft Outlook

1 Start Microsoft Outlook, using a Scalix profile.

2 Set up an account for the new mailbox.

3 Log in to that mailbox.

4 Choose Tools > Send/Receive. This verifies a connection to the server.
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Task 6: Reconfiguring Auto-Forward
for the New Scalix Mailboxes

This chapter covers the process for cancelling the auto-forward on Scalix mailboxes and 
then updating the Microsoft Exchange directory via the synchronization command.

Contents
This chapter includes the following information:

• “Introduction” on page 51

• “Removing the Forwarding Address” on page 51

Introduction

After provisioning the new Scalix mailboxes from the directory entries, do the following:

• Remove the forwarding (SMTP) address on Scalix mailboxes

• Use the omldapsync command to update the Microsoft Exchange directory

Both tasks can be accomplished with the ommigu command as outlined here.

Removing the Forwarding Address

To reconfigure auto forwarding

1 Log in to Scalix.

2 Open a terminal window and enter the following:

ommigu -n “Exchange display name” --raf

This command removes the auto-forwarding to Microsoft Exchange mailboxes.

It also updates other mailbox settings to indicate that the mailbox is associated with a 
migrated user and is ready for use.

3 To run omldapsync in interactive mode, enter the following:

omldapsync -i <syncid>
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where syncid is the actual agreement name.

4 At the prompt, enter 3 to update the directory. The results scroll on-screen.
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Task 7: Configuring Message
Forwarding from Exchange to Scalix

This chapter covers the procedure for routing all new mail to Scalix.

Contents
This chapter includes the following information:

• “Introduction” on page 53

• “Adding Alternate Recipient Information for a Single Mailbox” on page 54

• “Adding Alternate Recipient Information for Several Mailboxes” on page 55

Introduction

At this point, you configure Microsoft Exchange to route all new mail messages to Scalix 
server mailboxes. This enables you to migrate data from what are now legacy Microsoft 
Exchange mailboxes without having new mail or other data reaccumulate in just-migrated 
Microsoft Exchange mailboxes.

To do this, you configure an Alternate Recipient address for every Microsoft Exchange 
mailbox you plan to migrate. The Alternate Recipient address routes messages originally 
destined for the Microsoft Exchange mailbox to the Scalix server mailbox. This alternate 
address must exist in the Microsoft Exchange Global Address List (GAL).

The omldapsync command already added a Microsoft Exchange custom recipient entry for 
each mailbox in the current migration group. This custom recipient entry contains an SMTP 
address that routes to the Scalix server mailbox. You must now record/add these custom 
recipient entries in Microsoft Exchange as the alternate recipients for each mailbox.

There are two methods you can use to add Alternate Recipient information in Microsoft 
Exchange:

• One entry at time

• Multiple entries at one time

Each of these methods is detailed in this chapter.
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Adding Alternate Recipient Information for a Single 
Mailbox

To add Alternate Recipient information for a Microsoft Exchange mailbox

1 Start either the Microsoft Exchange Administration (for Microsoft Exchange 5.5) or Sys-
tem Manager application (for Microsoft Exchange 2000, 2003, or 2007).

2 Open the Site > Recipients list (or whichever list you have created) for your 
Microsoft Exchange site.

3 Locate the first mailbox associated with a user you are migrating to Scalix server, and 
double-click the entry. A properties window appears.

4 Click the Delivery Options tab.

5 Click the Modify button. The Mailbox window appears.

6 Make sure Global Address Files is selected in the drop-down list at the top right.
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7 Scroll through the left-hand column and find the directory entry with a globe icon that 
has the same name as the user’s mailbox.

8 Select the globe entry and click Add. The selected directory entry appears in the col-
umn to the right.

9 Click OK to close the Mailbox window.

10 When the properties window reappears, click OK to put the custom recipient entry into 
effect.

Adding Alternate Recipient Information for Several 
Mailboxes

Typically, a migration from Microsoft Exchange to Scalix server includes hundreds of users. 
Therefore, adding Alternate Recipient information one mailbox at a time is inefficient.

Using the Exchange Import and Export tools in conjunction with modified output files, you 
can add hundreds of alternate recipients to existing Microsoft Exchange mailboxes at the 
same time.

To add Alternate Recipient information for several Microsoft Exchange mailboxes

1 Start either the Microsoft Exchange Administration (for Microsoft Exchange 5.5) or Sys-
tem Manager application (for Microsoft Exchange 2000, 2003, or 2007).

2 Choose Tools > Directory Export. The Directory Export window appears.

3 To create a directory export file of Microsoft Exchange mailboxes, make these entries:

• The default Microsoft Exchange server and Home server names are accept-
able

• The default settings/selections in Export objects, Logging level, and Sepa-
rators areas are acceptable

• Do not check Include hidden objects 

Note There is a listing for this user’s mailbox—with no icon—as well as a second listing with a 
globe icon, representing the custom recipient that routes incoming mail to this user’s Scalix 
mailbox.
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• Click the Export File button

• When a window appears, name this file and pick a target folder

• Enter a name that identifies the contents of the output file, and make sure the .csv 
extension is present.

4 Click Export to start the process.

Modifying the Output File
Typically, you are migrating users in groups that are a subset of the container you specify in 
step 3 above. Therefore, you must modify the output file so that it contains only the 
mailboxes to which you want to add Alternate Recipient information.

To modify the output file

1 Start Microsoft Excel.

2 Choose File > Open, and open the output file from your directory export.

3 Choose File > Save As. The Save As window appears.

4 Save the file with a different file name.

5 Verify that the output file ends with column M, and that column N is empty.

6 In cell N1 (of column N), type “Alternate Recipient” as the column header.

7 Save these changes.

Entering Custom Recipient Container and Alias Name Parameters
Before you modify the exported-directory output file in Excel, be aware:

• The output file displays the following string in Column E:

/o=Organization/ou=Site/cn=Custom_Recipient_Container/cn=alias_name

• The Excel output file displays the following string in Column L (the Obj-Container 
header):

/o=XYZ/ou=XYZNA/cn=America

Using the Microsoft Exchange Administration application, you can determine that 
omldapsync stored the custom recipients in the America-CR container.

To complete the Alternate Recipient entry process for your Microsoft Exchange mail-
boxes

1 With your exported directory output file open in Excel, enter the following string at the 
bottom of the spreadsheet (in the first empty row below all existing entries):

/o=XYZ/ou=XYZNA/cn=America-CR/cn=

2 Enter a concatenation formula in cell N2 that adds the string from the static cell and the 
value in column E. For example, if you enter static data in cell A120, cell N2 must have 
the following formula:

Tip Write down the name and folder location of this file.
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=concatenate($A$120,E2)

3 Apply the same formula for all other entries in column N. Select (highlight) cell N2 and 
press Ctrl+c to copy the contents. Highlight all the other entries in column N and press 
Ctrl+v to paste the contents.

The text string that displays in the Alternate Recipient column contains four parameters 
(with delimiters).

/o=Organization/ou=Site/cn=Custom_Recipient_Container/cn=alias_name

Here are the Alternate Recipient column parameters.

4 Verify the accuracy of the data, then choose File > Save As to save the file with a 
different name. Make sure you click Yes at the Retain the Format prompt.

5 Choose Tools > Import > Select File to import the file into Microsoft Exchange.

You can use the default values for Account creation, Logging level, and Separators. The 
Container value is where the mailboxes (not the custom recipients) reside.

Use the Microsoft Exchange Administration application to check the properties of a sampling 
of mailboxes, especially the Delivery Options tab where an Alternate Recipient appears.

Parameter Description

Organization Displayed in column L.

Site Displayed in column L.

Custom_Recipient_
Container

The container into which omldapsync inserted the Custom Recipient infor-
mation. Use the Microsoft Exchange Administration application to obtain the 
name of the container.

alias_name

The Alias Name displays in column E, and the text string you enter in column 
N depends on the alias_name value.The rest of the string is identical for 
each cell. You can enter static information in a single cell and use the Con-
catenate function in Excel to combine the data from column E in the same 
row.
57



Scalix Migration Guide | Task 7: Configuring Message Forwarding from Exchange to Scalix
58



Task 8: Migrating Mailbox Data

After you modify the Microsoft Exchange server with Scalix server mailbox information and 
provision the target mailboxes on the Scalix server, you can migrate mailbox data. This 
chapter explains how to do it with the Scalix Migration Tool.

Contents
This chapter includes the following information:

• “Requirements” on page 59

• “Introduction” on page 59

• “Extracting Microsoft Exchange Mailbox Data” on page 61

• “Copying .pst Files into Scalix” on page 62

• “Creating the Target Mailboxes” on page 63

• “Running the Scalix Migration Tool” on page 64

• “Additional Notes” on page 65

Requirements

• Scalix 10.0 or higher. For foreign-language mailboxes, migration can only take place 
with Scalix 11.0 or higher.

• Scalix Connect 10.0 or higher

• Microsoft Office 2000 or XP computer with Service Pack 2

Introduction

The Scalix Migration Tool is a command-line-based Windows application that moves mailbox 
data from the source server (Microsoft Exchange) to the destination server (Scalix) in a two-
part process:

• Using ExMerge to extract the mailbox data from Microsoft Exchange into .pst files

• Moving the data from the .pst files into Scalix
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Migration is a read-only process that does not change mailbox contents in any way. The tool 
works by opening the source mailbox at root, and then traversing the folder hierarchy 
copying messages and other mailbox data from each source folder. Once the copy is done, 
the migration tool makes sure the new mailbox exists on the destination server, then pastes 
the contents into it. As it pastes the data, it updates any changes to internal e-mail 
addresses that it encounters. These internal address updates are done according to the 
latest data in the LDAP server and are executed only on the destination server. When it 
finishes with one folder, it moves on to the next until all mail folders have been copied over.

“Hidden messages” that store display data or other message parameters automatically 
transfer during this process.

If the tool encounters a problem with a specific message or folder, it logs the information 
and continues with the migration until it is done. For that reason, it is essential that you 
review the logs after any migration to see what messages, if any, the tool skipped and why. 
You can manually copy those messages over later if needed.

Procedure Overview
The process for using the Scalix Migration Tool is:

• Install ExMerge (explained later) and configure it to extract .pst files from your 
Microsoft Exchange environment

• Build (or use an existing) Windows XP machine, with Office 2003 installed, including 
Microsoft Outlook 2003. This is the migration workstation.

• Create a directory on the migration workstation to run the tool from (C:\SMT is recom-
mended), and save the sxmigrate.exe program in this directory

• Perform a few test mailbox extracts from the Microsoft Exchange environment with 
Exmerge.exe, then copy these machines to the local drive of the Windows migration 
workstation, into the directory where sxmigrate.exe exists

• Create the target mailboxes on Scalix (use Scalix Management Console or omaddu com-
mands)

• Do a test run to load a few mailboxes. The mailbox must already exist on Scalix. Typi-
cally, ExMerge names the .pst file with the relative distinguished name (RDN) attribute 
of the given mailbox. Once you get a clean migration, do the remainder as a batch pro-
cess.

Testing Using One or a Few Mailboxes First
Before you begin mass extractions, try extracting one mailbox, then importing it in to Scalix 
to verify the process’ efficacy. Once a successful process is proven, you can undertake batch 
extractions.
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Extracting Microsoft Exchange Mailbox Data

The Microsoft Exchange Mailbox Merge Program (Exmerge.exe) enables you to extract data 
from mailboxes on a Microsoft Exchange server. The Microsoft Exchange server version of 
this program is included in the Microsoft BackOffice Resource Kit, Second Edition. The 
Exchange 2000 Server version of Exmerge is included on the Microsoft Exchange 2000 server 
CD in the Support\Utils\I386\Exmerge folder.

One of the options this tool offers is to write each user’s mailbox data into individual .pst 
files. The Scalix Migration Tool can be used to then read each of the .pst files and load the 
data into the user’s corresponding Scalix mailbox.

To run the exmerge.exe program

1 At the Microsoft Exchange server containing the mailboxes you want to migrate, run 
exmerge.exe.

2 In the welcome screen, click Next.

3 At the next screen, select the Two step merge option and click Next.

4 At the next screen, select Copy data to Personal Folders and click Next.

5 At the next screen, enter the name of the Microsoft Exchange server from which you 
want to extract mailbox data and click Next.

At this point, you can select the Options button, which provides additional filtering 
capabilities against the mailbox data. For example you can base the amount of data 
extracted by dates.

6 The next screen prompts for the mailboxes you want to merge. Choose specific mail-
boxes or all mailboxes.

7 At the next prompt, select the destination directory to write the .pst files to.

At this point, also write the files to a network file share that is inaccessible by the Win-
dows computers to be used to run the Scalix Migration Tool.

8 The final screen shows a progress bar and ultimately completes, after which you can 
click Finish. At this point the .pst files have been created in the target directory spec-
ified on the prior screen.

Note If using ExMerge, the export language needs to match the native language of the mailbox. If 
the two languages do not match, string properties are exported incorrectly.
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Copying .pst Files into Scalix

Once all Microsoft Exchange data has been extracted into .pst files, you can use the 
migration tool to copy the data over to Scalix.

sxmigrate Command and its Parameters
The basis of the Scalix Migration Tool is the sxmigrate command. An example is:

sxmigrate –s pst:///c:/test/mailbox.pst –d “scalix://Test User:pass-

word@<fqdn>” –dir ldap://<fqdn>/cn=users,dc=Scalix,dc=local?mail –dirauth 

<username>@scalix.local:password1

The command has several options, as outlined in the table.

* In the Scalix Migration Tool, the -s, -d, and -dir options use URLs as locators. The form the 
URL takes can vary. Here are several examples:

• For the source .pst file: –s pst:///c://test/mailbox.pst

This specifies the source mailbox as the .pst file located in c:\test\mailbox.pst. The 
mailbox is specified as a .pst URL. Notice the three slashes. The first two are part of the 
URL spec, the third is to specify an empty or non-existent hostname. Also notice the use 
of forward slash in the URL instead of backslash.

• For the destination Scalix server: –d “scalix://Test User:password@stin-
gray.scalix.com”

This specifies the destination mailbox as the Scalix mailbox “Test User” located on the 
server stringray.scalix.com. The password for the mailbox is defined as “password” and 

Table 1: Options for the sxmigrate Command

Option Description

-s Designates the source mailbox. The mailbox location is expressed in the form of a URL.*

-d Designates the destination mailbox. The mailbox location is expressed in the form of a URL.*

-dir

Designates the location of the LDAP directory that the Scalix Migration Tool refers to when updating any changes 
to internal e-mail addresses that it encounters during migration. This LDAP directory can be the Microsoft 
Exchange Active Directory (AD) directory, the Scalix SYSTEM directory, or any suitable directory that can pro-
vide the old e-mail address information and the new e-mail address information.
The LDAP directory location is expressed in the form of a URL.*

-diroff Designates the credentials to access the LDAP directory if needed. This parameter is optional because some 
directories require credentials while others do not. Many can be accessed anonymously.

-log Designates the path and file name for the log file.

--copy Copies mailbox data to the destination server without the additional updating of internal e-mail addresses.

--fixup Updates internal e-mail addresses without copying the data over to the destination server.

--ex55 Tells the migration tool that the source data is coming from Microsoft Exchange 5.5.

--noui Suppresses the user interface.
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follows the mailbox name after a colon character. Again, this is consistent with the URL 
RFC.

• For an LDAP server: –dir ldap://exchang1.scalix.com/cn=users,dc=Scalix,dc=local?mail

This specifies the directory to use for directory fixup. In this example, the source 
exchange directory is used because the SMTP address does not change as a part of this 
migration. This method has no additional requirements on the Scalix server. If the Scalix 
directory is to be used, then a new attribute must be synchronized over from the source 
exchange directory (typically proxyAddresses à omLegacyEmailAddresses).

This is an LDAP URL, the server name is exchange1.scalix.com. The DN to the user root 
is cn=users,dc=Scalix,dc=local (in our example server) and the attribute to use is the 
mail attribute. See an example of a Scalix server in the help screen. If a –dir parameter 
is provided, then it is assumed that if the destination mailbox is a Scalix mailbox, the 
Scalix directory is used (equivalent to specifying on the command line “-dir ldap://stin-
gray.scalix.com/o=Scalix”omLegacyEmailAddress”)

Creating the Target Mailboxes

Once you have performed a few test mailbox extracts from the Microsoft Exchange 
environment with ExMerge.exe and have copied these to the local drive of the Windows 
migration workstation, you can move on to the next step. Remember that the .pst files must 
be copied into the directory where sxmigrate.exe exists.

The next step is to create the target mailboxes on Scalix. For this, use the Scalix 
Management Console. For more on how to create mailboxes in the Scalix Management 
Console, see the Scalix Administration Guide. If you want to use the command line, use the 
omaddu command.

Note Running sxmigrate.exe displays the tool’s help screen.
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Running the Scalix Migration Tool

After creating the target mailboxes, the next step is to execute the sxmigrate program. 
Because the specifics of the commands you use vary according to your setup, we provide 
only a sample command line.

To migrate users with the Scalix Migration Tool

1 Download the tool on the Windows migration workstation (in C:\SMT or elsewhere) and 
unzip.

2 Run several test mailbox migrations individually. The mailbox must already exist on 
Scalix. Typically ExMerge names the .pst file with the RDN attribute of the given mailbox 
(ldapsearch it; you will see).

A sample command is:

C:\SMT>sxmigrate -s pst:///c:\smt\rdn.pst -d "scalix://Bart 

Jones:mailpass@sxserver.abcco.com"

 -dir "ldap://exserver.abcco.com/cn=Recipients,ou=Chi-

cago,o=ABCco?mail" -dirauth "cn=exservice":Pa$$w0rd

 --ex55

where:

• The name of the .pst file created by exmerge.exe is rdn.pst

• The Scalix user account (common name) is Bart Jones, whose Scalix password is 
mailpass

• The Scalix server FQDN is sxserver.abcco.com

• The Microsoft Exchange server FQDN is exserver.abcco.com

• The Microsoft Exchange organizational hierarchy is cn=Recipients,ou=Chi-
cago,o=ABCco

• Microsoft Exchange SMTP addresses are loaded in the “mail” attribute (sometimes 
rfc822Mailbox is used here)

• Exservice is an account in Microsoft Exchange that has “service account” privileges 
on all levels of the hierarchy (the Administrator account can also typically be used), 
with a password of Pa$$w0rd

3 Once you successfully migrate several individual mailboxes, try a small batch.

4 When that succeeds, try a larger batch.

Alert If you are migrating from Microsoft Exchange 5.5, you must include the -ex55 option with the 
command.

Note This procedure does not support cross-system free/busy retrieval. So if one user is still on 
Microsoft Exchange and another user has been migrated to Scalix, you see valid free/busy infor-
mation for the migrated user once Microsoft Outlook or Scalix Web Access has published it. But 
you do not see it for the first user. In addition, only Microsoft Outlook and Scalix Web Access pub-
lishes free/busy information for Scalix. This must be done once a user has been migrated or they 
do not display as having any free/busy information.
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Additional Notes

A few additional things to keep in mind when using the Scalix Migration Tool:

• Typically exmerge.exe creates the .pst file names with the RDN attribute of the given 
mailbox

• You can use ldapsearch from a Linux host to make sure you get the search base and hier-
archy that are correct against the Microsoft Exchange environment, and also reveal the 
RDN of each object

• You can use multiple migration workstations running in parallel

• While the 10.0.x builds of Scalix Connect can be used, it is best to use Scalix Connect 
11.x
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Task 9: Decommissioning Microsoft
Exchange Mailboxes

This chapter explains how to deactivate Microsoft Exchange mailboxes, preventing them 
from being accessed by their users without deleting them.

Contents
This chapter includes the following information:

• “Introduction” on page 67

• “Decommissioning a Mailbox” on page 67

• “Decommissioning Multiple Mailboxes” on page 68

Introduction

When you complete migration of all the mailboxes and mailbox data, you can decommission 
the Microsoft Exchange mailboxes. This process makes them unusable without deleting 
them. Because a custom recipient of the same name already exists in the Global Address List 
(GAL), you can hide the Microsoft Exchange mailboxes without adversely affecting the 
system.

This task results in the deactivation of all Microsoft Exchange mailboxes, preventing them 
from being accessed by their users.

You have the choice of decommissioning a single mailbox or multiple mailboxes.

Decommissioning a Mailbox

To decommission a mailbox

1 Start the Microsoft Exchange Administration application.

2 Open the container (by default, “Recipients”) containing the migrated mailboxes.

3 Double-click any mailbox entry, to open the Properties window.
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4 Click the Advanced tab.

5 Enable the Hide from address book check box.

6 Click OK to save the change and close the window.

Decommissioning Multiple Mailboxes

To decommission Microsoft Exchange mailboxes

1 Open the backup file you created previously.

2 Verify that Column M contains a header named Hide from AB (address book) and has 
a value of 0 (zero).

3 Change the value in column M to 1.

4 Save the file.
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You can now import the file into Microsoft Exchange

1 Start the Microsoft Exchange Administration application.

2 Click Tools > Directory Import. The Directory Import window appears.

3 Choose from the following options:

• Click Import File and locate and open the Excel file

• Use the default values for the Account creation, Logging level, and Sepa-
rators areas

• The Container value indicates where the mailboxes (not the custom recipients) 
reside

4 Click Import. A status window appears and closes when the task is complete.

Verifying the Decommissioning
1 Start the Microsoft Exchange Administration application or Microsoft Outlook.

2 Verify that the mailboxes are no longer visible in the Microsoft Exchange GAL.
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How Phased Migration Works

This chapter illustrates the concepts in phased migration to explain what is done and why. It 
starts with a sequence of pictures showing how phased migration works on a per-server 
basis.

Contents
This chapter includes the following information:

• “Introduction” on page 73

• “Mailbox Management During Coexistence” on page 80

• “Coexistence in a Single Picture” on page 84

Introduction

In a phased migration, you have a lot of user accounts and data, so you migrate them in 
smaller groups, a few at a time. You set up a state of coexistence in which both Scalix and 
legacy mail servers communicate with one another while you move batches of user 
accounts/data at strategic intervals.

Important! It is imperative that each server not share the same Domain Name System (DNS) 
entry, but have distinct addressing, as shown. The separate DNS records must be in effect all 
through migration, as well as afterwards.

Figure 1: Use Different Domain Names

sx1.acme.netmail.acme.net
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Step 1

Before migration — All corporate e-
mail is managed by Microsoft 
Exchange.

Step 2

Before migration — The new Scalix 
server is installed and configured, 
ready for use. All corporate e-mail is 
still managed by the legacy server.

All that is needed is (1) to make sure 
that Scalix and the legacy system can 
cooperate/co-exist while (2) you do 
the migration of the users and their 
data.



Step 3

The contents of the legacy system’s 
directory are synchronized to Scalix.

This can be done with one of three 
command-line utilities:

• omldapsync

• omloadfile

• sxaa

Step 4

Using the new Scalix directory as the 
source, migration-ready mailboxes 
are created for all listed users and 
groups.

(All of these mailboxes are locked.)

If you use sxaa, directory pointers are 
created for all listed users and 
groups.



Step 5

An auto-forward action is applied to 
each new Scalix mailbox, to 
automatically redirect any 
communications sent to Scalix back to 
the still-active legacy server.

The legacy server is still managing 
incoming and outgoing e-mail.

Step 6

Divide your legacy-system users into 
small groups of users that can be 
migrated at one time. For example 
20, 50, or 100; time and resources are 
the guides to the exact number you 
choose.

Exchange



Step 7

Start Migration — The migration of a 
group of user accounts and their data 
begins with copying the contents of 
the first group of mailboxes.

Step 8

Finish Migration — When migration of 
the first group is complete, you can:

1. Turn off auto-forwarding on the 
just-migrated Scalix mailboxes.

2. Activate an alternate address on 
each of the just-migrated legacy 
mailboxes.

3. Or use .forward files.

The legacy system now forwards all 
incoming mail to the Scalix version of 
each mailbox.



Step 9

The mailboxes are present on both 
systems. Migration now transfers the 
data from selected legacy mailboxes 
to Scalix in an orderly manner.

The legacy system still manages all 
incoming e-mail and scheduling 
communications. It forwards all 
incoming messages to the just-
migrated Scalix users. Scalix manages 
outgoing communications from all 
migrated mailboxes. The servers are 
actively coexisting.

Step 10

Migration is complete. You stop all 
auto-forwarding from Scalix to the 
legacy system. All mail going to the 
legacy system is redirected to Scalix 
mailboxes.

Firewall

MX

Exchange

Scalix



Step 11

Done — The MX record is revised so 
that all mail goes to the Scalix server.

From now on, the Scalix server 
manages all e-mail, scheduling, and 
any other services formerly managed 
by the legacy system.

The legacy server is decommissioned 
and reused for other purposes.
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Mailbox Management During Coexistence

Mailbox management tasks begin after a directory synchronization with the legacy system. 
You then complete a directory-based provisioning of new mailboxes on the Scalix server.

You now have the same users on each server, though in different states.

Next, you create auto-forwarding from the new mailboxes on Scalix that route mail to the 
legacy mail system. This is a precautionary step, because the Scalix mailboxes are not yet 
receiving incoming mail.

Mailbox User – Joe Smith

 Joe.smith@xyzcorp.com

 Joe.smith@xyz.com

 Jsmith@oldco.com

Mailbox User – Mary Jones

 Mary.jones@xzycorp.com

 Mary.jones@xyz.com

 Mjones@oldco.com

Custom Recipient – Sam Jones

 Sam.jones@hotmail.com

Public Distribution List – Sales

 sales@xyzcorp.com

Remote Recipients (3)

 Joe.smith@xyzcorp.com

 Joe.smith@xyz.com

 Jsmith@oldco.com

 

 Mary.jones@xzycorp.com

 Mary.jones@xyz.com

 Mjones@oldco.com

 Sam.Jones@hotmail.com

Public Distribution List - Sales

 sales@xyzcorp.com

Mailbox User – Joe Smith

 Joe.smith@xyzcorp.com

 Joe.smith@xyz.com

 Jsmith@oldco.com

Mailbox User – Mary Jones

 Mary.jones@xzycorp.com

 Mary.jones@xyz.com

 Mjones@oldco.com

Custom Recipient – Sam Jones

 Sam.jones@hotmail.com

Public Distribution List – Sales

 sales@xyzcorp.com
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At this point, you can add a new, correct Scalix-specific address to each Scalix mailbox, and 
then turn off the precautionary auto-forward.

Now you start to create a custom recipient that matches each of the users on the legacy 
system, and each recipient points to that user’s Scalix-addressed mailbox.

Locked Mailbox – Group A

 Joe.smith@xyzcorp.com

 Joe.smith@xyz.com

 Jsmith@oldco.com

 Auto-forward to joe.smith@xyzcorp.com

Locked Mailbox – Group B 

 Mary.jones@xzycorp.com

 Mary.jones@xyz.com

 Mjones@oldco.com

 Auto-forward to mary.jones@xyzcorp.com

Remote Recipient - Sam Jones 

 Sam.jones@hotmail.com

Public Distribution List - Sales

 sales@xyzcorp.com

Mailbox User – Joe Smith

 Joe.smith@xyzcorp.com

 Joe.smith@xyz.com

 Jsmith@oldco.com

Mailbox User – Mary Jones

 Mary.jones@xzycorp.com

 Mary.jones@xyz.com

 Mjones@oldco.com

Custom Recipient – Sam Jones

 Sam.jones@hotmail.com

Public Distribution List – Sales

 sales@xyzcorp.com

Mailbox – Group A

 Joe.smith@xyzcorp.com

 Joe.smith@xyz.com

 Jsmith@oldco.com

 Joe.smith@sx1.xyzcorp.com

 Auto-forward to joe.smith@xyzcorp.com

Mailbox – Group B 

 Mary.jones@xzycorp.com

 Mary.jones@xyz.com

 Mjones@oldco.com

 Auto-forward to mary.jones@xyzcorp.com

Remote Recipient - Sam Jones 

 Sam.jones@hotmail.com

Public Distribution List - Sales

 sales@xyzcorp.com

Mailbox User – Joe Smith

 Joe.smith@xyzcorp.com

 Joe.smith@xyz.com

 Jsmith@oldco.com

Mailbox User – Mary Jones

 Mary.jones@xzycorp.com

 Mary.jones@xyz.com

 Mjones@oldco.com

Custom Recipient – Sam Jones

 Sam.jones@hotmail.com

Public Distribution List – Sales

 sales@xyzcorp.com

-NEW!-
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The next step is to add a redirection address to each legacy mailbox, pointing to the 
corresponding custom recipient. This routes all incoming mail from the original mailbox to 
the custom mailbox (on the legacy system) then to the Scalix mailbox.

Once this is in effect, you can deactivate the original mailbox, as the custom recipient 
redirection process now channels all incoming mail to that user’s Scalix mailbox.

Mailbox – Group A

 Joe.smith@xyzcorp.com

 Joe.smith@xyz.com

 Jsmith@oldco.com

 joe.smith@sx1.xyzcorp.com

Mailbox – Group B 

 Mary.jones@xzycorp.com

 Mary.jones@xyz.com

 Mjones@oldco.com

 Auto-forward to mary.jones@xyzcorp.com

Remote Recipient - Sam Jones 

 Sam.jones@hotmail.com

Public Distribution List - Sales

 sales@xyzcorp.com

Mailbox User – Joe Smith

 Joe.smith@xyzcorp.com

 Joe.smith@xyz.com

 Jsmith@oldco.com

 

Mailbox User – Mary Jones

 Mary.jones@xzycorp.com

 Mary.jones@xyz.com

 Mjones@oldco.com

Custom Recipient – Sam Jones

 Sam.jones@hotmail.com

Custom Recipient – Joe Smith

 joe.smith@sx1.xyzcorp.com

Public Distribution List – Sales

 sales@xyzcorp.com

Mailbox – Group A

 Joe.smith@xyzcorp.com

 Joe.smith@xyz.com

 Jsmith@oldco.com

 joe.smith@sx1.xyzcorp.com

Mailbox – Group B 

 Mary.jones@xzycorp.com

 Mary.jones@xyz.com

 Mjones@oldco.com

 Auto-forward to mary.jones@xyzcorp.com

Remote Recipient - Sam Jones 

 Sam.Jones@hotmail.com

Public Distribution List

 sales@xyzcorp.com

Mailbox User – Joe Smith

 Joe.smith@xyzcorp.com

 Joe.smith@xyz.com

 Jsmith@oldco.com

 Redirect to joe.smith@sx1.xyzcorp.com

Mailbox User – Mary Jones

 Mary.jones@xzycorp.com

 Mary.jones@xyz.com

 Mjones@oldco.com

Custom Recipient – Sam Jones

 Sam.jones@hotmail.com

Custom Recipient – Joe Smith

 joe.smith@sx1.xyzcorp.com

Public Distribution List – Sales

 sales@xyzcorp.com
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As you repeat this process with all your legacy user mailboxes, you migrate your system 
successfully, the two servers coexist effectively, and your mail system users do not notice 
any effect on their service.

Mailbox – Group A

 Joe.smith@xyzcorp.com

 Joe.smith@xyz.com

 Jsmith@oldco.com

 joe.smith@sx1.xyzcorp.com

Mailbox – Group B 

 Mary.jones@xzycorp.com

 Mary.jones@xyz.com

 Mjones@oldco.com

 Auto-forward to mary.jones@xyzcorp.com

Remote Recipient - Sam Jones 

 Sam.Jones@hotmail.com

Public Distribution List

 sales@xyzcorp.com

Mailbox User – Joe Smith

 Joe.smith@xyzcorp.com

 Joe.smith@xyz.com

 Jsmith@oldco.com

 Redirect to Joe.Smith@sx1.xyzcorp.com

Mailbox User – Mary Jones

 Mary.jones@xzycorp.com

 Mary.jones@xyz.com

 Mjones@oldco.com

Custom Recipient – Sam Jones

 Sam.jones@hotmail.com

Custom Recipient – Joe Smith

 joe.smith@sx1.xyzcorp.com

Public Distribution List – Sales

l

[Deactivated mailbox
for Joe Smith]
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Coexistence in a Single Picture

The effect of coexistence, as shown, is to make sure all incoming and outgoing mail goes 
through the legacy mail system, until all mailboxes are migrated.

Once a matching Scalix mailbox is ready and all the auto-forwarding/custom redirection 
takes effect, the legacy server continues to manage all incoming mail for that user, but it 
ends up on the Scalix server in the migrated mailbox.

At this point, outgoing mail from that user’s mailbox goes directly to the networks from the 
Scalix server, with the user never noticing a thing. All other un-migrated mailboxes are 
served as before by the legacy mail system.
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Task 1: Activating Auto-Forwarding on
Microsoft Exchange

This chapter covers the first phased migration task, which is to activate Auto-Forwards on 
the Microsoft Exchange Internet Mail Server. During the coexistence period, mail is routed 
from the Microsoft Exchange server using its Internet Mail Service (IMS) to a Scalix server 
within the same Internet domain, by means of the auto-forwarding.

Contents
This chapter includes the following information:

• “Requirements” on page 85

• “Activating Auto-Forwarding on Microsoft Exchange” on page 86

Requirements

Before starting this task, you must have completed the following:

• Activated a Microsoft Exchange server Administrative user account (login)

• Installed and fully configured a Scalix server

• Completed the Domain Name System (DNS) setup for the Scalix server. The DNS setup is 
critical. If your Microsoft Exchange server is registered as, for example, “com-
pany.mail.com” then you need to assign the Scalix server a distinct DNS record, such as 
“company.scxmail.com”.

• Opened a terminal window as root on the Scalix server

• On your migration Windows workstation (with access to both Scalix and Microsoft 
Exchange servers), create the needed e-mail user profiles (using the Windows Mail con-
trol panel). There must be one for “Exchange” and one for “Scalix”, that have the 
proper settings. See the Scalix Client Deployment Guide for instructions on creating a 
Scalix profile.

• Created a Microsoft Exchange container to which you intend to import Scalix mailboxes
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Activating Auto-Forwarding on Microsoft Exchange

To activate auto-forwarding on a Microsoft Exchange server

1 Start the Microsoft Exchange Administrator application.

2 Select the site to be migrated, and then choose File > New Other > Recipients 
Container. A blank properties window appears.

3 Enter a name for the new recipient container (for example, Scalix Mail Users) in both 
the Display name and Directory name fields.

4 Click OK. After a pause for processing, the new container name appears in the 
Microsoft Exchange Administration explorer view.

5 In the main Microsoft Exchange Administration window, click the Connections button 
in the toolbar (second last in the figure shown here).
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The explorer view expands, to show “Connections”.

6 Click the Connections node in the explorer view.

7 Double-click Internet Mail Service in the listing on the right. The Internet Mail Ser-
vice Properties window appears.

8 Click the Internet Mail tab, if it is not already in view.
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9 Click the E-Mail Domain button. The E-mail Domain window appears.

10 Click Add. The Add E-Mail Domain window appears.

11 In the E-Mail Domain field, enter the fully qualified domain name (host.domain.ext) 
of the destination Scalix server.

12 Click the Advanced options button. The Advanced options window appears.

13 From the Send Microsoft Exchange rich text formatting drop-down list, 
select Always.

14 Disable the Disable Automatic Replies to the Internet check box.

15 Click OK to close this window.

16 Click OK to close each of the other open windows. An alert window appears, prompting 
you to restart the Internet Mail Service.

17 Click OK to close this window.
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Stopping and Restarting the Exchange Internet Mail service
1 Open the Services control panel; click Start > Settings > Control Panel > 

Services. The Services control panel appears.

2 Locate and select the Microsoft Exchange Internet Mail Service.

3 Click Stop.

4 Leave the Services control panel open, and, after the “Started” notation is erased from 
Microsoft Exchange, restart the service by selecting the name and clicking Start.

This completes the activation of auto-forwarding.
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Task 2: Preparing the Microsoft
Exchange Users Distribution List

This chapter describes how to create a distribution list that includes all Microsoft Exchange 
users in the environment. This list is used during the public folder coexistence and migration 
process.

Contents
This chapter includes the following information:

• “Creating the Microsoft Exchange Users Distribution List” on page 91

Creating the Microsoft Exchange Users Distribution 
List

To prepare the Microsoft Exchange users distribution list

1 On the Microsoft Exchange server, start the Microsoft Exchange Administrator applica-
tion.

2 Select a container that contains Microsoft Exchange users you want to migrate.

Note The default selection/container is “Recipients”.
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3 Select File > New Distribution List. A blank Properties window appears.

4 Enter Exchange Users in both the Display name and Alias name fields.

5 Click the Modify button in the Members area. A distribution list window appears.

6 Select all the Microsoft Exchange users in the Global Address List (left column) and click 
Add. The selected names appear in the right column as Distribution List members.

7 Click OK to close this window and save your entry. Depending upon the number of users 
in your system, this can take some time to complete.

8 Click OK to close each of the remaining Microsoft Exchange Administration windows.
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Task 3: Configuring a TNEF route
for Microsoft Exchange Users

This chapter covers the configuration of the Transport Neutral Encapsulation Format (TNEF) 
route, which enables Microsoft Exchange recipients in the Scalix environment.

Contents
This chapter includes the following information:

• “Introduction” on page 93

• “Configuring TNEF Routes” on page 93

Introduction

Scalix server uses the Sendmail message transfer agent (MTA) and Simple Mail Transfer 
Protocol (SMTP) to route messages between servers. To configure Scalix server for 
coexistence, you must configure a TNEF route on Scalix server for the Microsoft Exchange 
recipients in the Scalix server directory. When LDAP synchronization occurs, the Microsoft 
Exchange recipient entries are assigned to a Scalix server mailnode that corresponds to the 
omAddress value in sync.cfg file. By default, the omAddress value in the sync.cfg file is set 
to remote,tnef.

Configuring TNEF Routes

To configure a single route between the Microsoft Exchange server and the Scalix 
server (with TNEF encoding)

1 Log in to the Scalix server, and open a terminal window.

2 Enter this command:

omshowrt -q all

A table appears, showing the existing routes on the Scalix server. This table is organized 
in three columns, these being queue, mailnode, and format.

Alert If you route messages directly between Scalix and Microsoft Exchange servers during coex-
istence, message formatting is downgraded to plain text.
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UNIX    internet         MIME

UNIX    internet,tnef    TNEF

LOCAL    scalix1

where scalix1 is the name of a mailnode.

3 Enter this command:

omaddrt -m <route_name> -q unix -i tnef

where route_name is a name of your own choosing that represents this new route. Write 
down the new route name for use in future steps. This new route uses the SMTP queue 
while retaining all TNEF attributes.

A confirmation message appears:

omaddrt: Route successfully added

4 To verify the existence and content of the route, re-enter the omshowrt command:

omshowrt -q all

The routes table appears, listing your new entry:

UNIX    internet         MIME

UNIX    internet,tnef    TNEF

LOCAL   scalix1

UNIX    <route_name>     TNEF

5 To verify the route configuration, enter this command:

omshowux

A list of configurations appears, as shown here:

MIME Mailnode     : internet

TNEF Mailnode      : internet,tnef

TNEF Domains       :

Dist List Abbreviation Limit : 0

6 Make sure that internet,tnef is listed as the TNEF Mailnode attribute. This ensures 
that TNEF routing is enabled.

7 To list and verify the mail routes to the UNIX queue for SMTP delivery, enter this com-
mand:

omshowrt -q unix

A table appears, listing routes and formatting:

internet            MIME

internet,tnef       TNEF

<route_name>         TNEF

Note TNEF routing also supports domain-based encoding. See the MAN pages for omconfux and 
omshowux for more information.
94



Scalix Migration Guide | Task 3: Configuring a TNEF route for Microsoft Exchange Users
8 To verify the routing configuration, send a test e-mail message to both of the following:

• From a Scalix server user to a Microsoft Exchange user

• From a Microsoft Exchange server user to a Scalix user

For example, send a message from an address in this format:

sxadmin@mailnode.domain.ext

to an address in this format:

exchange_user@domain.ext

If the message exchange is successful, the route configuration is complete.
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Task 4: Changing the LDAP Setting on
the Scalix Server

This chapter covers changing a setting on the Lightweight Directory Access Protocol (LDAP) 
server for a high numbers of users.

Contents
This chapter includes the following information:

• “Introduction” on page 31

• “Changing the LDAP Server Setting” on page 31

If you are migrating more than 1,000 user mailboxes from Microsoft Exchange to Scalix, you 
must modify an LDAP setting on the Scalix server to increase the default capacity.

For instructions, see “Task 1: Changing the LDAP Setting on the Scalix Server” on 
page 31. The procedure is the same for a flash or phased migration.
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Task 5: Creating the
Synchronization Agreement

This chapter covers the synchronization agreement needed to create/provision users on the 
Scalix system, based on user records from the Microsoft Exchange server.

Contents
This chapter includes the following information:

• “Adding Administrator Rights to a User Account” on page 33

• “Obtaining Microsoft Exchange Server Values” on page 35

• “Creating the Synchronization Agreement” on page 35

For instructions, see “Task 2: Creating the Synchronization Agreement” on page 33. The 
procedure is the same for a flash or phased migration.
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Task 6: Completing the Initial
Directory Synchronization

This chapter covers how to run the initial directory synchronization.

Contents
This chapter includes the following information:

• “Introduction” on page 39

• “Synchronizing the Directories” on page 40

• “Resetting a Synchronization” on page 41

• “Note About Changing Entries” on page 42

For instructions, see “Task 3: Completing the Initial Directory Synchronization” on 
page 39. The procedure is the same for a flash or phased migration.
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Task 7: Updating Microsoft Exchange
and Scalix Directories

During a phased migration, your Microsoft Exchange directory and mailboxes have the 
potential to be modified daily, so you need to regularly update the Microsoft Exchange and 
Scalix server directories. This chapter explains how.

Contents
This chapter includes the following information:

• “Updating Microsoft Exchange and Scalix Directories” on page 103

Updating Microsoft Exchange and Scalix Directories

To synchronize Microsoft Exchange and Scalix directories

1 Log in to the Scalix server.

2 Run omldapsync in interactive mode by entering the following command:

omldapsync -i <syncid>

where syncid is the name for your Microsoft Exchange-Scalix migration synchronization 
agreement.

3 Enter 3 to update the directories.

This command synchronizes the directories on the Scalix and Microsoft Exchange servers 
by comparing the current export file (which is created by selecting this option) with the 
previous export file. The command adds, deletes, and modifies entries in the appropri-
ate directory.

4 The results scroll on-screen. When the update completes, you are prompted to exit.

Tip You can automate this directory update process by creating a script file that executes omlda-
psync with the appropriate options, which are detailed in the MAN page. You can schedule 
regular execution of the script as a cron job.
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Task 8: Updating the Client Directory
Access

Scalix provides a client interface to the directory that acts as an index of all users. You can 
use this index to specify the directory entries that clients (such as Microsoft Outlook, 
Internet clients, and LDAP clients) can access. When you modify the directory through any 
interface, including omldapsync, you must update client directory access before clients can 
view any new entries in the directory. This chapter explains how.

Contents
This chapter includes the following information:

• “Updating the Client Directory Access Index” on page 105

Updating the Client Directory Access Index

You must update the client directory access (CDA) index after you successfully synchronize 
the Scalix and Microsoft Exchange directories.

To update the client directory access index

1 Log in to the Scalix server.

2 Enter the following command:

omexeccda

The results scroll on-screen as follows:

Fetching all entries from Directory  ... Please wait

Sorting Directory entries            ... Please wait

Building Directory Access Tables     ... Please wait

Tip You can automate this process by including this script in a cron job.
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Task 9: Hiding Directory Entries in
Scalix Server

During the coexistence period, you may need to hide unwanted entries in the Scalix server 
directory, and at the same time, hide them from the Microsoft Outlook Address Book. This 
requires the modification of a parameter in the Scalix server directory, as described in this 
chapter.

Contents
This chapter includes the following information:

• “Hiding Directory Entries in Scalix” on page 107

Hiding Directory Entries in Scalix

In the following example, the Microsoft Exchange entry for scheduling and free/busy lookup 
exports to Scalix server are named “Microsoft Schedule+ Free\/Busy Connector (BAMEX55)”.

To hide selected directory entries

1 Enter the following command (example):

omsearch -e common-name=adm*

The following information appears on-screen:

COMMON-NAME=AdminSch=Microsoft Schedule+ Free\/Busy Connector 

(BAMEX55)/OU1=exchange/S=(BAMEX55)/OU2=bamail/ALIAS=AdminSch/INTER-

NET-ADDR=AdminSch@bamail.net/G=Microsoft/LDAP-OBJECT-CLASS=Mailbox-

Agent=organizationalPerson=person=Top=ldapsync-first/I=S COMMON-

NAME=Administrator/OU1=exchange/S=Administrator/

OU2=bamail/ALIAS=Administrator/INTERNET-ADDR=Administrator@bam-

ail.net/LDAP-OBJECT-CLASS=organizationalPerson=person=Top=ldapsync-

first

2 To hide the COMMON-NAME=AdminSch=Microsoft Schedule+ Free\/Busy Connector 
(BAMEX55) directory entry, enter:

ommodent -e common-name=adminsch -n EX-CDA-DIRECTORY=1

The following information appears:
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Modified 1 entry in the Directory

3 To update the client directory access (CDA) directory, enter:

omexeccda
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Task 10: Preparing for Public Folder
Migration

This chapter explains how to prepare for public folder migration.

Contents
This chapter includes the following information:

• “Introduction” on page 109

• “Determining Which Public Folders to Migrate” on page 110

• “Resetting Permissions on Public Folders” on page 110

• “Reorganizing Public Folders and Data” on page 110

• “Creating Public Folders on Scalix Server” on page 112

• “Checking Your Work” on page 113

Introduction

The process during a phased migration for migrating public folders from Microsoft Exchange 
is: you migrate the Microsoft Exchange public folder data to Scalix server; and you auto-
forward messages between the Microsoft Exchange and Scalix public folders. The forwarding 
is both ways, meaning from Microsoft Exchange to Scalix and from Scalix to Microsoft 
Exchange. If you do not migrate the folders and enable auto-forwarding, duplicate messages 
can display in Scalix public folders, for example.

Scalix recommends creating a backup folder for your public folders before you begin the 
migration and coexistence process.

During the public folder data migration process, you can migrate all data and maintain the 
current folder structure, or migrate some data and use the public folder data migration 
process as an opportunity to delete old data and unwanted folders.

The Import/Export wizard in Microsoft Outlook manages the migration of public folder data. 
Before you begin migrating public folder data, you:

• Determine which public folders you want to migrate

• Reset the permissions on them
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• Reorganize them

• Prepare them

Each of these topics is outlined in this chapter.

Determining Which Public Folders to Migrate

When determining the public folders to migrate to Scalix, remember that any Microsoft 
Exchange user can potentially create and manage access to a public folder. Some public 
folders can be restricted and even administrators are unable to access or manage them. 
Alternatively, some organizations have policies where only administrators can create and 
manage public folders.

Scalix recommends that you notify all Microsoft Exchange users before you migrate public 
folders so that owners can consider whether to include their folders in the migration. Also 
notify users that a new public folder owner is established during migration and that all data 
messages are visible to an administrator.

Resetting Permissions on Public Folders

After you identify the public folders that you want to migrate, you must assign a new owner 
to each one so that you can:

• Export a .pst file to import into Scalix server

• Create a new rule using the Folder Assistant that enables cross-platform synchronization

For example, your organization designates one of your administrator accounts (that is part 
of an Administration group) to be the owner of all public folders within the organization.

Reorganizing Public Folders and Data

After you determine the public folders to migrate and configure the owner permissions for 
them, Scalix recommends that you create a “clean and migrate” directory where you can 
reorganize public folders and data.

To create a directory for reorganizing public folders and data

1 Using a Microsoft Exchange profile, log in to Microsoft Outlook as the designated public 
folders owner.

2 Click the All Public Folders folder (inside Public Folders).

Note Any folder that is restricted in Microsoft Exchange (a default role set to the value of None) is set to 
a default role of Publishing Author after it is imported into Scalix. This means they can create and 
read items in the folder, create subfolders, and edit and delete their own items. They are not the 
owner and cannot edit or delete other people’s items in the folder. If you want to restrict viewing of 
a public folder, change the default role to None after you create the public folder using the .pst 
import. This means that the folder is not visible. To view the various roles and how permissions 
vary, right-click a public folder in Scalix Web Access, for example, and view its permissions.
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3 Choose File > Folder > New Folder. The Create New Folder window appears.

4 Enter Clean and Migrate in the Name field.

5 Click OK.

6 When the Microsoft Outlook window reappears, right-click the Clean and Migrate 
folder and choose Properties. A properties window appears.

7 Make sure the following settings are in effect:

• Initial view on folder — Normal

• Drag/Drop posting is a — Move/Copy

• This folder is available to — All users with access permission

8 Click OK to save your settings and close the window.

9 Right-click all of the to-be-migrated public folders and drag them onto the Clean and 
Migrate folder.
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10 At the prompt, click Copy. The contents of all public folders are copied into this migra-
tion folder.

Creating Public Folders on Scalix Server

Based on the folders being migrated from Microsoft Exchange, create a matching set of 
public folders on the Scalix server. The name of each public folder must be exactly the same 
as the originating folder.

For example, if you want to migrate the Microsoft Exchange public folder “For Sale” to 
Scalix, enter this command on the Scalix server:

omaddbb -s “For Sale”

A public folder created as root by command has no owner. A public folder created instead in 
a client, such as Scalix Web Access, has an owner, which is the Premium user account that 
created it. Scalix recommends upgrading the sxadmin account from Standard to Premium 
user and creating the public folders in Scalix Web Access. Both methods follow.

To create public folders on a Scalix server by command

1 Enter the omaddbb command, for example:

omaddbb -s “For Sale”

Use this command to create all the other public folders. The confirmation message that 
appears on the Scalix server refers to bulletin boards, which is the same as a public 
folder:

Bulletin Board added

2 To create a subfolder, use the command

omaddbb -m “TOP” -s <“Folder Name”>

To create public folders in Scalix Web Access

1 Click File > New > Folder. In the window that appears, type a name for the entry, 
select an option from the drop-down list (e-mail and posts, contacts, or calendars), then 
click Public Folders to create it there.

2 Click OK to exit from the window and create the folder.

3 Create the rest of the folders.

A new folder gives users the role of Author, which means users can create and read items in 
it and edit or delete their items in it. They cannot create subfolders or edit or delete other 
people’s items in the folder. They cannot modify the permissions on the folder.

The easiest way to change the permissions on such folders is to upgrade the sxadmin 
account to Premium user, log in to Scalix Web Access, then right-click and change the 
permissions on the folders.

Tip The migration process provides the opportunity to delete legacy data from your public folders. 
The data that you decide to exclude (if any) from the migration process depends on the migration 
policies implemented by your organization. To remove unwanted messages, open the public fold-
ers and delete the messages that you do not want to migrate to Scalix.
112



Scalix Migration Guide | Task 10: Preparing for Public Folder Migration
Figure 1: Changing “Default” Permissions for Regular Users

Checking Your Work

You can check in Microsoft Outlook. You can also list public folders using a command.

To verify the success of your work

1 Start Microsoft Outlook, using the Scalix profile.

2 Open the public folders list.

3 Verify that the folders have been migrated from the Clean and Migrate folder.

To list public folders on a Scalix server

1 Run one of the following commands.

For top-level folders — omlistbbs

For all levels of folders — omlistbbs -d 0
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Task 11: Migrating Public Folders

This chapter explains the procedure for migrating public folders from Microsoft Exchange to 
Scalix.

Contents
This chapter includes the following information:

• “Requirements” on page 43

• “Exporting Public Folders from Microsoft Exchange” on page 43

• “Importing Public Folders for Scalix” on page 46

For instructions, see “Task 4: Migrating Public Folders” on page 43. The procedure is the 
same for a flash or phased migration.
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Task 12: Enabling Public Folder
Forwarding on Scalix Server

This chapter explains how to enable public folder forwarding in Scalix.

Contents
This chapter includes the following information:

• “Introduction” on page 117

• “Setting Up Forwarding” on page 118

• “Activating Forwarding” on page 119

• “Testing Your Work” on page 120

Introduction

The public folder coexistence process requires that you enable forwarding capabilities on 
the Scalix public folder, then create an Internet-routable e-mail address to be applied to 
public folders on Scalix. This address takes the form:

publicfoldername@scalixserver.yourcompany.com

Enabling forwarding allows a copy of a message posted to a given public folder in Scalix 
server to be forwarded automatically to a similarly-named public folder on Microsoft 
Exchange.

Two commands enable public folder forwarding on Scalix server:

• omaddent

• omaddbbsa

Examples
The specific use of omaddent results in a directory entry associated with the public folder 
and creates an SMTP address to receive inbound mail. It can be used three ways.
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Example 1 — Create a directory entry with accompanying e-mail address

We want to create a new Scalix-based public folder named “For Sale” for use by Acme 
Corporation mail users. The Internet domain is acme.net, on a mailnode named scalixserver. 
To do so, create a directory entry (each of the two items on a single line):

omaddent –e “S=+BB/G=For Sale /CN=For Sale/ OU1=scalixserver/OU2=acme/

DDT1=BB-NAME/DDV1=For Sale/

IA=ForSale@scalixserver.acme.net” 

Example 2 — Hide the new entry (and e-mail address) immediately after creation

To create and then hide the directory entry for the “For Sale” public folder on Scalix, enter 
the following:

omaddent –e “S=+BB/G=For Sale /CN=For Sale/ OU1=scalixserver/OU2=acme/

DDT1=BB-NAME/DDV1=For Sale/

IA=ForSale@scalixserver.acme.net/ EX-CDA-DIRECTORY=1” 

Example 3 — Retroactively hide the previously created (visible) entry

If we previously created the “For Sale” public polder and want to hide the entry, enter the 
following:

ommodent -e S=+BB/G=For Sale/CN=For Sale/OU1=scalixserver/OU2=acme -n EX-

CDA-DIRECTORY=1

Setting Up Forwarding

Run the omaddent command to enable forwarding of public folders, as outlined in the 
previous section.

To set up forwarding

1 Run the omaddent command in the following format:

omaddent –e “S=+BB/G=For Sale /CN=For Sale/ OU1=scalixserver/OU2=acme/

DDT1=BB-NAME/DDV1=For Sale/

IA=ForSale@scalixserver.acme.net”

The arguments of the omaddent command must include the following.

Note If the public folder name contains non-ASCII characters, such as Japanese characters or 
German umlauts, use DDV1-TX instead of DDV1 in the command.

Note If the public folder name contains non-ASCII characters such as Japanese characters or 
German umlauts, use DDV1-TX instead of DDV1 in the command.
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Update the client directory access after adding or modifying entries in Scalix; simply run the 
omexeccda command.

To update the client directory access index

1 Enter the following command:

omexeccda

Activating Forwarding

After you create a directory entry associated with the public folder, you must activate the 
forwarding option in the similarly-named Microsoft Exchange public folder. This is done by 
providing a “forward to external address” option in the Scalix server public folder 
synchronization mechanism.

The omaddbbsa command configures a forwarding address that forwards any new messages 
to the specified public folder to an address that you specify:

omaddbbsa –f /route/forwarding_address/ -s public_folder_name

For example, to configure forwarding from the Scalix “For Sale” public folder to the 
external SMTP address “ForSale@bamex55.bamail.net”, enter the following:

omaddbbsa –f /remote,tnef/IA=ForSale@bamex55.bamail.net –s “For Sale”

Table 1: omaddent Arguments

Parameter Description

S Must be set to +BB.

G Specifies the user-visible name of the public folder.

CN Specifies the Common Name that is required by the omldapsync command.

OU
Specifies the mailnode components, and you must enter the primary mailnode to route messages to the 
public folder server. Use the omshowmn command to display the primary mailnode. The primary mailnode 
displays with two asterisks (**) before the mailnode name.

DDT1 This is an internal tag that must be set to BB-NAME. Leaving the DDT1 blank causes Scalix server to route 
public folder messages to a UNIX gateway.

DDV1
This is an internal tag and must be set to the name of the public folder you are enabling. If the public folder 
name contains non-ASCII characters, such as Japanese characters or German umlauts, use DDV1-TX 
instead of DDV1.

INTERNET-
ADDR

This is the SMTP address that is used outside the Scalix server system to send messages to the public 
folder.

Note This option provides functionality equivalent to the Microsoft Exchange public folder forward-
ing rule, that is, only new public folder messages are synchronized between the Scalix and 
Microsoft Exchange servers. Modified and deleted messages are not synchronized.
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The remote,tnef parameter is the route that references the Microsoft Exchange server. This 
ensures that the forwarded messages preserve all MAPI properties.

Testing Your Work

To verify that the public folder forwarding mechanism is functioning, post a message to a 
public folder in Scalix, then check the corresponding folder in Microsoft Exchange to see if 
that message was successfully forwarded.
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Task 13: Enabling Public Folder
Forwarding on Microsoft Exchange

The final task in the public folder coexistence process is to enable forwarding capabilities on 
the Microsoft Exchange server. This chapter explains how.

Contents
This chapter includes the following information:

• “Introduction” on page 121

• “Requirements” on page 122

• “Activating Folder Forwarding” on page 122

Introduction

To complete bidirectional bulletin board message routing, you configure Microsoft Exchange 
public folders to forward a copy of a newly posted message to the Scalix public folders. The 
Microsoft Exchange server has custom recipients that have an SMTP address that reference 
similarly-named Scalix public folders. For example, the “For Sale” public folder, which now 
has a similarly-named public folder on the Scalix server, now has a custom recipient.

The Internet address for “For Sale”, like other custom recipients, references an external 
SMTP address (for example, ForSale@scalixserver.acme.net). You must then add a 
forwarding rule that enables the Microsoft Exchange server to forward a copy of a “For Sale” 
public folder message to the “For Sale” custom recipient. Microsoft Exchange then routes 
the message to the Scalix public folder named “For Sale”.

Note Notes in public folders cannot be forwarded to Scalix.
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Requirements

To prevent message loops, configure Microsoft Exchange to only forward messages posted by 
Microsoft Exchange mailbox users. The most efficient method is by using Distribution Lists.

Most organizations have a method of broadcasting messages to some or all members of an 
organization by using one or more Distribution Lists. However, you can also use Distribution 
Lists for public folder forward functionality.

Activating Folder Forwarding

Set up forwarding of new public folder content from the Microsoft Exchange server to the 
Scalix server.

To enable Microsoft Exchange to forward messages from Exchange public folders to 
Scalix public folders

1 Start Microsoft Outlook as the owner of a Microsoft Exchange-based public folder.

2 Right-click the public folder and choose Properties. The properties window appears.

3 Click the Administration tab.

4 Click Folder Assistant. The Folder Assistant window appears.
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5 Click Add Rule. The Edit Rule window appears.

6 Click From. The Choose Sender window appears.

7 Make sure Global Address List is selected in the Show Names from drop-down 
list.

8 Select a Microsoft Exchange distribution list (represented by two-headed icons) whose 
users you want to allow to post to public folders.

9 Click From to move that list to the right area.

10 Repeat this process to add other lists.
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11 Click OK to save the selections and close the Choose Sender window. The Edit Rule win-
dow reappears, displaying the selected groups.

12 Enable the Forward check box.

13 From the Method drop-down list, select Leave Message Intact.

14 In the To field, enter the Internet address of the similarly named public folder stored 
on Scalix.

15 Click OK to close the window and save the entries.

16 Click OK to close all other windows.

17 To test the success of your efforts, post a new message to a Microsoft Exchange public 
folder, then see if it is visible in the corresponding Scalix public folder.
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Task 14: Effective Distribution List
Coexistence

This chapter offers tips for effective coexistence of public distribution lists (PDLs), or 
groups.

Contents
This chapter includes the following information:

• “Introduction” on page 125

• “Creating the Distribution List and Custom Recipient” on page 125

Introduction

There is no central mechanism that synchronizes distribution lists. Instead, they are 
managed by either the Scalix or Microsoft Exchange system. Whichever system is not the 
manager must include a reference entry that sends a single message to the host system 
where the distribution list resides. The distribution list is then updated.

Although the Scalix or Microsoft Exchange system can manage distribution lists, Scalix 
recommends that you manage distribution lists in Microsoft Exchange until the end of the 
coexistence process.

As previously noted in “Task 2: Preparing the Microsoft Exchange Users Distribution List” on 
page 91, Scalix creates directory entries that represent Microsoft Exchange Distribution Lists 
and displays them as PDLs. To achieve this in Microsoft Exchange, you must create a 
Distribution List and add the Scalix server custom recipient of the same name.

Creating the Distribution List and Custom Recipient

To create a Distribution List and add the Scalix custom recipient

1 Start the Microsoft Exchange Administrator application.

2 Select the container from which you migrated Microsoft Exchange users (for example, 
Recipients).
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3 Choose File > New Distribution List. A Properties window appears.

4 Click the Modify button in the Members area.

5 Add all Scalix users to the Distribution List.

6 Enter a name in the Display name field.

7 Enter a name in the Alias name field. (It does not have to be different.)

8 Click OK to save your entries and close the properties window.

Updating Directory Information
1 Log in to Scalix.

2 Enter the following omldapsync directory-update command:

omldapsync -i <syncid>

where syncid is your existing synchronization agreement name.

3 When the omldapsync menu appears, enter 3 to update the directory.

Updating the Client Directory Access List
1 Enter this command:

omexeccda

This completes the task.

Alert Do not add ScalixAdmins, ScalixGroupAdmins, ScalixUserAdmins, ScalixUserAttributeAd-
mins, or querymgr to the new Scalix distribution list.
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Note
You cannot view Microsoft Exchange Distribution List members in Scalix (using either Scalix 
Connect for Microsoft Outlook or Scalix Web Access), but you can see the Distribution List 
name. If you were logged in to Scalix during the recent operations, exit and then restart 
Microsoft Outlook to refresh the displays.
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Task 15: Loading Scalix Mailboxes

This chapter explains how to provision Scalix mailboxes.

Contents
This chapter includes the following information:

• “Introduction” on page 49

• “Provisioning a Mailbox” on page 50

• “Verifying the New Mailbox” on page 50

The migration process requires that you convert Microsoft Exchange directory entries to 
Scalix server mailboxes. The principal tool is a Scalix command, ommigu. This command 
modifies Scalix server directory entries that represent Microsoft Exchange users.

For instructions, see “Task 5: Loading Scalix Mailboxes” on page 49. The procedure is 
the same for a flash or phased migration.

That chapter deals with a single mailbox entry. The next chapter outlines how to provision 
mailboxes in bulk.
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Task 16: Bulk Mailbox Provisioning
and Configuration

This chapter explains how to provision Scalix mailboxes in bulk.

Contents
This chapter includes the following information:

• “Introduction” on page 131

• “Using Microsoft Exchange Attributes to Provision Scalix Mailboxes” on page 132

• “Using Scalix Server Attributes to Provision Scalix Mailboxes” on page 133

• “Using the Userfile Option to Provision Scalix Mailboxes” on page 134

• “If You are Asked for Passwords” on page 134

Introduction

The ommigu script contains powerful filtering capabilities to organize users into migration 
groups. This enables you to migrate the users in your organization in phases. A phased 
migration implies for select users an extended coexistence period between Microsoft 
Exchange and Scalix.

Performing the tasks described in the “Loading Scalix Mailboxes” chapter provisions and 
configures a mailbox for use with Scalix server. ommigu filtering capabilities enable you to 
provision and configure groups of users based on:

• Microsoft Exchange attributes

• Scalix attributes

• A userlist text file

Each of these options is outlined here; choose one.
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Using Microsoft Exchange Attributes to Provision 
Scalix Mailboxes

To use Microsoft Exchange attributes to provision a group of users (mailboxes)

1 Use the –ldapfilter option as follows:

ommigu –ldapfilter “attribute=string” –h ldapserver

where:

• attribute represents the LDAP representation of the Microsoft Exchange attribute

• string represents the string within the Microsoft Exchange attribute

• ldapserver represents the server against which you are executing the query (typi-
cally, the Microsoft Exchange server itself)

For example:

ommigu –ldapfilter “l=Boston” –h ex55ord.xyzcorp.com –m “xyzcorp,hq”

Because the city attribute in Microsoft Exchange contains the LDAP representation of l, 
ommigu queries the Microsoft Exchange server for all users that contain the string Bos-
ton in the city field.

All user accounts matching this criteria are provisioned for use with Scalix.

2 Configure these user accounts for use with Scalix by entering:

ommigu –ldapfilter “attribute=string” –h ldapserver -–raf

3 Execute omldapsync in interactive mode by entering:

omldapsync -i <syncid>

where syncid is the name of the synchronization agreement that you created.

4 At the prompt, enter 3 to update the directory.
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Using Scalix Server Attributes to Provision Scalix 
Mailboxes

When the initial synchronization between Scalix server and Microsoft Exchange occurs (using 
omldapsync), most of the information stored in Microsoft Exchange directory attributes is 
mapped to corresponding attributes in the Scalix directory. So you can provision the Scalix 
system directory using either the –ldapfilter or –filter option.

Using the –ldapfilter option requires that you include the LDAP representation of the Scalix 
server attribute. Using the –filter option requires that you include the Scalix server name of 
the attribute (typically referred to as a tag).

To use Scalix server attributes (example)

1 Provision all users (mailboxes) in the Scalix directory with the given name of Mark by 
entering:

ommigu –filter “G=Mark” –show

The name of the Scalix server is not required.

2 Because the LDAP representation of this field is givenName, you can also provision the 
Microsoft Exchange server for all directory objects with a given name of Mark. To do so, 
enter the following command:

ommigu –ldapfilter “givenName=Mark” –h ldapserver –show

3 Configure these user accounts for use with Scalix by entering:

ommigu –ldapfilter “givenName=Mark” –h ldapserver -–raf

4 Execute omldapsync in interactive mode by entering:

omldapsync -i <syncid>

where syncid is the name of the synchronization agreement created by you.

5 At the prompt, enter 3 to update the directory.
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Using the Userfile Option to Provision Scalix Mail-
boxes

You bulk-provision and configure user accounts using the ommigu -userfile option. The 
userfile itself is a text file that lists the Scalix common name attribute for all users. Because 
the Scalix common name corresponds to the Microsoft Exchange display name attribute, you 
can use the directory export capabilities in the Microsoft Exchange Administration 
application to extract users to a comma-separated file.

To provision and configure a group of users (mailboxes) using the -userfile option

1 Using the Microsoft Exchange Administration application, extract the current users to a 
comma-separated file.

2 Edit the file to remove the user accounts that you do not want to migrate.

3 Save the file in .txt format, using the .txt extension.

4 Provision the mailboxes in this list by entering this command:

ommigu –userfile <path>/grp1.txt

where path is the location of the file and the name of the file is grp1.txt.

5 Configure these users for use with Scalix server by entering:

ommigu –userfile <path>/grp1.txt -–raf

6 Run omldapsync in interactive mode by entering:

omldapsync -i <syncid>

where syncid is the name of the synchronization agreement that you created.

7 At the prompt, enter 3 to update the directory.

If You are Asked for Passwords

1 If this prompt appears after you have entered 3:

INPUT: please enter password for EX_PASS=

enter the Microsoft Exchange migration user password.

2 When this prompt appears:

INPUT: please enter password for IM_PASS=

enter the Scalix server administrator password.
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Task 17: Reconfiguring Auto-Forward
for the New Scalix Mailboxes

This chapter covers the process for cancelling the auto-forward on Scalix mailboxes and 
then updating the Microsoft Exchange directory via the synchronization command.

Contents
This chapter includes the following information:

• “Introduction” on page 51

• “Removing the Forwarding Address” on page 51

For instructions, see “Task 6: Reconfiguring Auto-Forward for the New Scalix Mailboxes” 
on page 51. The procedure is the same for a flash or phased migration.
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Task 18: Configuring Message
Forwarding from Exchange to Scalix

This chapter covers the procedure for routing all new mail to Scalix.

Contents
This chapter includes the following information:

• “Introduction” on page 53

• “Adding Alternate Recipient Information for a Single Mailbox” on page 54

• “Adding Alternate Recipient Information for Several Mailboxes” on page 55

For instructions, see “Task 7: Configuring Message Forwarding from Exchange to Scalix” 
on page 53. The procedure is the same for a flash or phased migration.
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Task 19: Migrating Mailbox Data

After you modify the Microsoft Exchange server with Scalix server mailbox information and 
provision the target mailboxes on the Scalix server, you can migrate mailbox data. This 
chapter explains how to do it with the Scalix Migration Tool.

Contents
This chapter includes the following information:

• “Requirements” on page 59

• “Introduction” on page 59

• “Extracting Microsoft Exchange Mailbox Data” on page 61

• “Copying .pst Files into Scalix” on page 62

• “Creating the Target Mailboxes” on page 63

• “Running the Scalix Migration Tool” on page 64

• “Additional Notes” on page 65

For instructions, see “Task 8: Migrating Mailbox Data” on page 59. The procedure is the 
same for a flash or phased migration.
139



Scalix Migration Guide | Task 19: Migrating Mailbox Data
140



Task 20: Decommissioning Microsoft
Exchange Mailboxes

This chapter explains how to deactivate Microsoft Exchange mailboxes, preventing them 
from being accessed by their users without deleting them.

Contents
This chapter includes the following information:

• “Introduction” on page 67

• “Decommissioning a Mailbox” on page 67

• “Decommissioning Multiple Mailboxes” on page 68

When you complete migration of all the mailboxes and mailbox data, you can decommission 
the Microsoft Exchange mailboxes. This process makes them unusable without deleting 
them.

For instructions, see “Task 9: Decommissioning Microsoft Exchange Mailboxes” on 
page 67. The procedure is the same for a flash or phased migration.
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Task 21: Post-Migration and
Coexistence Closure Tasks

The chapter outlines the tasks to complete the migration of Microsoft Exchange users and 
data to Scalix and to end coexistence between Scalix and Microsoft Exchange.

Contents
This chapter includes the following information:

• “Achieving Successful Coexistence” on page 143

• “Managing Distribution Lists” on page 144

• “Switching Distribution List Management to Scalix” on page 144

• “Switching PDL Management After Coexistence” on page 147

• “Continuing Coexistence” on page 148

Achieving Successful Coexistence

For a phased migration, a successful state of coexistence and a satisfying migration to Scalix 
depend on the following:

• All inbound Internet mail must continue to be routed to the legacy mail service until the 
last user is migrated to Scalix. Only then can the mail exchanger (MX) records can be 
changed to direct mail to the Scalix service.

• Every newly migrated Scalix user needs access to a complete address book listing all 
users, whether on Scalix or on the legacy system. When they send e-mail to any user, it 
needs to be routed to the appropriate environment (wherever the destination recipi-
ent’s mailbox truly exists). This means you need mailbox forwarding mechanisms and/or 
directory entries within the Scalix environment as well, to make sure mail routes to the 
legacy environment.

• Each time a user (or a group of users) is migrated from the legacy environment to Scalix, 
auto-forwarding mechanisms must be active and directory entries must be updated
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Managing Distribution Lists

As a phased migration proceeds, one serious question arises: how to coordinate Distribution 
Lists. Some recipients on a Distribution List still reside in the old environment (Microsoft 
Exchange) while some recipients are migrated to the new environment (Scalix).

If you delete Microsoft Exchange mailboxes (after successful migration to Scalix server), any 
Alternate Recipient information (referencing the new Scalix server mailbox) is removed 
from all Microsoft Exchange Distribution Lists. If this poses a problem, you can manually 
insert the reference to the Scalix server mailbox back into all Microsoft Exchange 
Distribution Lists to which the just-migrated users belong.

However, during the migration process, Scalix server provisions directory entries as 
mailboxes with automatic redirection instead of redirection-only entries. The benefit of 
provisioning entries in this manner is that it enables the option of mirroring the structure 
and members of Public Distribution Lists (PDLs) on Scalix server at anytime. As users are 
migrated from Microsoft Exchange to Scalix server, you do not have to delete and add the 
directory entry into the list. Similarly in the Microsoft Exchange environment, the 
management of Distribution Lists during the migration to Scalix is simplified because you do 
not have to remove mailboxes.

Although you eventually add (and hide) Alternate Recipient information to Microsoft 
Exchange mailboxes, you do not need to remove mailboxes and replace them with custom 
recipients during the migration process.

Switching Distribution List Management to Scalix

You can switch Distribution List management from Microsoft Exchange to Scalix either during 
the coexistence period or after coexistence. (The latter is outlined in the next section.) This 
requires the creation of a Microsoft Exchange Custom Recipient entry with the Internet 
address of a specific Scalix server Public Distribution List and a unique display name (for 
example, SALES-PDL).

To switch distribution list management to Scalix

1 Create a custom recipient pointing to the Scalix group; in the Microsoft Exchange 
Administrator application, choose File > New Custom Recipient. The New E-mail 
Address window appears.
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2 Select Internet Address and click OK. The Internet Address Properties window 
appears.

3 In the E-mail address field, type the Scalix group’s full e-mail address, for example 
sales@mailserver.scalix.company.com

4 Click OK to proceed. The Properties window appears.

5 Click the Display field and type the Scalix group’s name (probably the same name as 
the original Microsoft Exchange PDL).

6 Click the Alias field and type the scalix group’s full e-mail address. Ignore all the other 
fields.

7 Click Apply, then click OK, to close this window and save your entries.

8 When Microsoft Exchange reappears, open the Lists menu and choose Custom 
Recipients. The new custom recipient appears in the now-visible list.

9 Remove the Microsoft Exchange auto-forward from the Scalix group/Public Distribution 
List that refers to the original Microsoft Exchange Public Distribution List.
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10 Set up the auto-forwarding for the Microsoft Exchange group; in Microsoft Exchange 
Administrator, double-click the original PDL entry to open that list’s properties window.

11 Click the Modify button below the users list. The Distribution List window appears.

12 Select and delete all the entries in the Distribution List Members list.

13 In the same window, locate the custom recipient (representing the Scalix group).

14 Select it and click Add ->.

15 Click OK to save the change and close the window.

16 When the Properties window reappears, click Apply, then click OK to save your 
changes.

17 Now hide the custom recipient from Microsoft Exchange view. First, start the Microsoft 
Exchange Administrator application.

18 Open the List menu (on the Microsoft Exchange Administrator toolbar) and choose 
Custom Recipients.

19 Locate and double-click the Scalix-group custom recipient in the list that appears.

20 When the Properties window appears, click the Advanced tab.

21 In the Custom Recipient Options, enable the Hide from address book check box.

22 Click Apply to activate your changes, then click OK to close the properties window.

23 You can exit the Microsoft Exchange Administrator application.

What Happens?
Any remaining Microsoft Exchange users can address messages to the same Microsoft 
Exchange-based Distribution List that now has only one member—the custom recipient that 
contains the Internet address of the corresponding Scalix server Public Distribution List.

You can now switch administration of this distribution list (including additions or deletions of 
recipients) to the Scalix server copy.
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Switching PDL Management After Coexistence

If you switch Distribution List management after coexistence (when there are no more 
actively used mailboxes on Microsoft Exchange), you must add all relevant users to the 
Scalix server Distribution List in one of two ways:

• Using Scalix Management Console

• By running the omaddpdln command in a terminal window

Adding a number of names to a Scalix Public Distribution List can be made efficient by 
extracting the original Microsoft Exchange recipient list to a text file, then formatting the 
file for importation into Scalix.

Copying the PDL from Microsoft Exchange
1 In the Microsoft Exchange Administrator application, open the Recipients container 

where the Distribution Lists are stored.

2 Right-click the appropriate Distribution List entry and select Properties. The Proper-
ties window opens.

3 In the General tab, click Modify. A Distribution List window appears.

4 Select all of the list’s users (by clicking the Members list and pressing Ctrl+A) and 
copy them to the Windows clipboard.

5 Close the Distribution List and Properties windows.

6 Open a new Notepad or Wordpad document and paste the collection of user information 
into the document window.

7 Save this document as Dlist.txt

8 Exit the Microsoft Exchange Administrator application.

Formatting the List File for Importation
To process the text file in Microsoft Excel for use in Scalix

1 Open a new Excel workbook, with the active cell being A1.

2 Click Data > Import External Data > Import Data. The Select Data Source 
window appears.

3 Locate and select the user names text file.

4 Click Open. The Text Import wizard appears.

5 In the first wizard screen, click the Delimited button.

6 Click Next. The second wizard screen appears.

7 Enable the Delimited check box and uncheck any others.

8 Make sure that both first and last names are sorted into the same cell/column as shown 
in the preview area of the window.

9 Click Next. The third wizard screen appears. No changes are needed.

10 Click Finish. The Import Data window appears.
147



Scalix Migration Guide | Task 21: Post-Migration and Coexistence Closure Tasks
11 Click OK. (The default location is the current worksheet, in cell =$A$1.) Row 1 displays 
names from the list, one first/last name pairing per cell.

12 Select the entire row. (Selecting empty cells does not affect this procedure.)

13 Copy the row’s contents to the Windows clipboard.

14 Open a new Excel workbook.

15 Click Edit > Paste Special. The Paste Special window appears.

16 Enable the Transpose check box. (All other default settings are acceptable.)

17 Click OK to complete the pasting of data. Excel redistributes the first and last names in 
Column A.

18 Due to the default column width, the name entries can appear to spill into column B and 
C. Widen Column A to verify that each first/last name entry fits in its own Column A 
cell.

19 Save this file/workbook as a text file for importation into Scalix.

20 Print the file.

Continuing Coexistence

If you are planning to operate both Microsoft Exchange and Scalix servers after the initial 
migration, you run the omldapsync command on a regular basis to synchronize directories. 
This is entirely feasible, but remember the following as you perform regular updates of both 
server directories:

Do not change or delete user records on the Scalix server. Always edit the records on 
the originating Microsoft Exchange/IMAP server.

Then, start a new omldapsync operation to update the Scalix server.

If you synchronize directories on Scalix and Microsoft Exchange, the operation involves two 
sequential unidirectional synchronizations that are entirely independent of each other:

• Scalix users become “foreign address” entries in the Microsoft Exchange Global Address 
List (GAL)

• Microsoft Exchange users become “Internet” users in Scalix

There is no duplication of directory entries; during omldapsync, each set of users is treated 
differently on the target server. Scalix users are kept in a separate Microsoft Exchange 
recipients container, and Microsoft Exchange users are never given Standard or Premium 
user status in Scalix.

As a result, problems can arise from mistaken assumptions about “synchronization”.

As an example, you synchronize a “Jane Smith” user record from Microsoft Exchange to 
Scalix. Later, you either edit the Scalix “Jane Smith” record on Scalix or delete that record 
from Scalix. (If a record originates in Microsoft Exchange, resist the impulse to edit or delete 
it in Scalix.) It later becomes apparent that it was wrong to change or delete the “Jane 
Smith” record. You assume that the record will be replaced in the next omldapsync 
operation, but you discover nothing has changed afterwards.

The explanation is simple, as is the solution:
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• omldapsync does not compare each directory (Scalix and Microsoft Exchange) for 
changes or deletions in shared records, so it does not detect the missing “Jane Smith” 
record on Scalix and replace it

• You must manually edit the files used by omldapsync (details follow), specifically the 
“Jane Smith” record”, to force omldapsync to reload the “Jane Smith” record from 
Microsoft Exchange to Scalix

How omldapsync Works
omldapsync, when run, takes a snapshot of the entire Scalix directory, including Scalix users 
and “Internet” users. omldapsync also polls the Microsoft Exchange directory for both kinds 
of users and notes them in the same snapshot. It then compares the aggregate snapshot file 
with the previously-saved snapshot file. Any additions or changes are then recorded in a 
[name] file that is exported to Microsoft Exchange and to Scalix.

Again, there is no direct comparison of the two server’s user directories. An intermediary 
process is used.

Editing the omldapsync [name] File
If you accidentally delete a record on Scalix or Microsoft Exchange that originated from the 
other server, you can force omldapsync to reload the original record on the destination 
server.

1 Log in to Scalix as root.

2 Use a text editor to open the snapshot file that contains the original “Jane Smith” 
record.

~/ldapsync/[name_of_sync_agreement]/search.last

3 Find and delete the “Jane Smith” record and the following carriage return.

4 Save the change to the snapshot file.

5 Restart omldapsync. After comparing the latest collection of user records with the pre-
vious snapshot, it creates a [name] file that replaces the missing “Jane Smith” record on 
the destination server.
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Part 4

Migrating an IMAP System 
to Scalix
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Completing an IMAP-to-IMAP
Mail System Migration

If your current mail system allows only IMAP4 or POP3 access and/or if the system has no 
LDAP v2 support, you can migrate the user accounts and their data from the legacy system 
to Scalix. This chapter outlines a flash migration from any e-mail system that supports IMAP4 
protocol to Scalix, which also uses the IMAP4 protocol.

This particular migration process employs a set of utilities included in E-Mail Shuttle 
software by GeM Solutions. A trial version is available from 
http://www.gem-si.com/downloads.cfm

Requirements

• Windows 2000 or XP computer

• Microsoft Office 2000 or XP

• An extractor code for E-Mail Shuttle, provided by Scalix or with E-Mail Shuttle

• The administrator account login for Scalix

• The administrator account login for your legacy IMAP server

Installing E-Mail Shuttle

The installation program is EmailShuttle.exe.

1 Launch the E-Mail Shuttle installation wizard. You can accept the default directory or 
change it to C:\Program Files. Also be sure to choose the following:

• Extractor — IMAP4 Compliant E-mail System 

• Loader — IMAP4 Compliant E-mail System 
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Configuring E-Mail Shuttle

You configure E-Mail Shuttle using the Mission Control application.

To configure E-Mail Shuttle

1 Click Start > All Programs > GeM Solutions, Inc > GeM E-Mail Shuttle > 
GeM E-Mail Shuttle Extractor > GeM E-Mail Shuttle Mission Control for 
IMAP4. The IMAP Extract Mission Control window appears. The default settings in the 
tabs are acceptable, with two exceptions: the Misc and IMAP tabs.

2 Click the Misc tab.
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3 In the Authorization Code field, type the extractor code if it is not already entered.

4 Click the IMAP 4 tab.

5 In the Host Name field, type the fully-qualified domain name of the legacy IMAP4 
server.

The default Host Port of 143 is an acceptable value for IMAP4.

Leave the Launch Pad Name and Launch Pad Password fields empty.

6 Click OK to update the \eshuttle\Extractor\IMAP4\eshuttle.ini file with your new 
entries and exit the application.

Loading the Mailboxes on the Scalix Server

Scalix recommends testing the following migration process on a small sampling of users 
before undertaking the migration of your entire system.

The next step is to load (provision) the mailboxes on the Scalix server. There are several way 
to do this:

• Use Scalix Management Console

• Use the omaddu command

• Use a combination of omldapsync and ommigu

• Use more advanced auto-forwarding mechanisms

The most important consideration is to make sure that the primary Internet address of the 
Scalix user is loaded correctly before initiating any mailbox migration.

The first phase is to create a file that lists users on the legacy IMAP4 mail system. The file 
name is “shuttlin*” (with an asterisk) and have a file extension of “.txt”.

Example: shuttlin1.txt

There are two ways to create a shuttlin*.txt file:

• Use the Shuttlin Editor application provided

• Use any text editor that can save the contents of a file as ASCII text
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Both methods are outlined here; choose one.

Using Shuttlin Editor to Create a User File
The Shuttlin Editor is installed by default with the product. It can also be launched as 
EShuttlinEdit.exe from the \Extractor\IMAP\Users\ folder.

To use the Shuttlin Editor to create the user file

1 Start the Shuttlin Editor from the Start menu (... > Tools > GeM E-Mail Shuttle 
Shuttlin File Editor). The Shuttlin Editor window appears.

2 Click File > Open/New. A window opens.
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3 Use the window to navigate to the target folder:

\Extractor\IMAP\Users

4 Enter a name for the file in the File name field, ending the filename with a “.txt” 
extension. Make sure the file type is “Text file”.

5 Click Open. The Select Shuttlin file type window opens.

6 Enable the IMAP option.

7 Click OK to save the file type selection. The Shuttlin Editor window reappears, display-
ing the new file name in the title bar.

8 Complete the following fields to add information for a current user:

User Name — The login name used for access to the IMAP4 server. Quite often this is 
formatted as “First Last” or “FirstLast” or “First.Last”. On some systems, it can be an 
Internet e-mail address (first.last@yourcompany.com).

First Name — The first name of the user, sometimes referred to as the given name

Last Name — The last name of the user, sometimes referred to as the surname
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Forwarding Address — The Internet address for the user on the legacy IMAP4 
server, in the format name@pop.company.net

Password — The password used to access the mailbox on the legacy IMAP4 server

DBTitle — The primary Internet address of the corresponding mailbox on the Scalix 
server

Path — The password used for access to the Scalix mailbox

DBServer — The fully qualified domain name of the Scalix server

DBName — This value is always DBTitle 

9 Click Add to store this user’s information.

10 Save the file; click File > Save.

11 Exit from the application; click File > Exit.

Using a Text Editor or Spreadsheet to Create a User File
You can also create a shuttlin*.txt file using an application (Microsoft Word, Excel, Notepad, 
and so on) that saves files in a text (.txt) format. The contents must be organized according 
to these requirements:

• The file must begin with a single ES_System^IMAP^ line

• Each user’s information must be placed in a separate ES_Export line

• Use “^” as the delimiter character

An example of a file called shuttlingroup1.txt is shown here for users Ed Fry and Jane 
Rogers:

ES_System^IMAP^

ES_Export^Ed Fry^^^^pa$$w0rd^ed.fry@cpgcorp.com^Ed^Fry^ed.fry@cpg-

corp.com^123456^scalix.cpgcorp.local^DBTitle^

ES_Export^Jane.Rogers@scalixtester.com^^^^xandros^Jane.Rogers@scalixt

ester.com^Jane^Rogers^Jane.Rogers@scalixtester.com^xan-

dros^scalix1.scalixtester.com^DBTitle^

Note The Create button has no purpose. You can ignore it for this task.
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Extracting the Mailbox Contents

After completing the shuttlin*.txt file, you can run the E-Mail Shuttle extractor. This 
application, IMAPExtract.exe, can be found in the \Extractor\IMAP folder.

1 To run this application, either click the .exe file, or open a command window, change to 
the directory, and type

IMAPExtract console

The extractor script automatically open the user’s list and starts the extraction.

The results of the extraction process are displayed on the screen and logged in the 
\Extractor\IMAP\LogFile folder.

A sample of successful results is shown here:

Tue Dec 07 13:33:04 2004    User [Dan Smith] Summary:

Tue Dec 07 13:33:04 2004   

Tue Dec 07 13:33:04 2004    Run Summary:

Tue Dec 07 13:33:04 2004    Successfully unloaded: 4 total messages

Tue Dec 07 13:33:04 2004                           3 total folders

Tue Dec 07 13:33:04 2004    Errors:

Tue Dec 07 13:33:04 2004     0 total messages not unloaded due to errors

Tue Dec 07 13:33:04 2004     0 total folders not unloaded due to errors   

Loading the Extracted Data onto Scalix

After extracting the data from your legacy mailboxes, you can run the loader and transfer 
the data from the previously-created .txt file to Scalix mailboxes. This application can be 
found in the \Loader\IMAP folder, named Imap_Loader.exe.

1 To run this application, click the .exe file, or open a command window and enter

Imap_Loader ?debug

Results of the data loading process are displayed on the screen and logged in the 
\Loader\IMAP\LogFile folder.
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omldapsync Synchronization
Command

This chapter outlines use of the omldapsync command for synchronizing the Scalix and 
Microsoft Exchange servers.

Contents
This chapter includes the following information:

• “Introduction” on page 163

• “Using the omldapsync Command” on page 164

• “Command-Line Options” on page 165

• “Command Examples” on page 166

Introduction

Successful communication between the Scalix and Microsoft Exchange servers requires that 
you synchronize entries in both the Scalix and Microsoft Exchange directories. Later in the 
migration process, the directory entries are used to set up mailboxes on the Scalix server 
and enable coexistence between both e-mail systems.

The directory synchronization process uses the Lightweight Directory Access Protocol (LDAP) 
as the method for exchanging directory entries. Coexistence uses a single connection point 
between Scalix and Microsoft Exchange.

The omldapsync command is the tool that you use to synchronize the directories. The 
omldapsync command is executed on the Scalix server and uses a mapping file that is 
created during the Scalix server installation. If required, you can edit the mapping file at 
any time to make configuration changes.

For every synchronization agreement, omldapsync creates a directory that contains 
configuration files, logging files, and Import and Export subdirectories. The Import directory 
contains files used during the Microsoft Exchange-to-Scalix synchronization, and the Export 
directory contains files used during the Scalix-to-Microsoft Exchange synchronization.

Because LDAP is typically used as a directory search tool rather than a directory 
synchronization utility, you must modify some default settings for LDAP on the Scalix and 
Microsoft Exchange servers to enable the directory integration to operate correctly.
163



Scalix Migration Guide | omldapsync Synchronization Command
Using the omldapsync Command

You can use the omldapsync command two ways:

• Interactive mode (this section)

• Command-line mode, which allows you more control over omldapsync (next section)

When you execute omldapsync in interactive mode, you can do the following:

• Create the synchronization agreement

• Perform an initial synchronization of the directories

• Update the directories based on changes since the last synchronization

• Accept manual error-correction modifications to the directories (for errors detected 
during the synchronization)

To use the omldapsync command in interactive mode

1 To execute omldapsync in interactive mode and perform omldapsync tasks, enter the 
following command:

omldapsync -i <syncid>

where syncid is the name of the synchronization agreement that you created. If you 
need to create one, see “Creating the Synchronization Agreement” on page 35.

The following menu options appear.

0. Display this menu

Displays the omldapsync menu.

1. Configure the LDAP dir sync settings

Allows you to configure the synchronization agreement. If an agreement does not exist 
for the agreement name you enter, omldapsync creates a new directory structure and 
corresponding files.

2. Force a complete (re)load of the directory

Allows you to perform an initial synchronization of the Scalix and Microsoft Exchange 
directories. omldapsync extracts all entries from the Microsoft Exchange directory and 
creates a file that it imports to the Scalix directory. omldapsync also extracts all entries 
from the Scalix directory and creates an import file for the Microsoft Exchange direc-
tory.

Note that you perform an initial synchronization once. While it is possible to execute an 
“initial synchronization” several times, omldapsync returns errors if you do not delete 
all remote recipient entries in both the Scalix and Microsoft Exchange directories before 
executing the initial synchronization again. To accept these errors, select option 4.

3. Update the directory after some changes

Synchronizes the directories on the Scalix and Microsoft Exchange servers by comparing 
the current export file (which is created by selecting this option) with the previous 
export file.
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omldapsync adds, deletes, and modifies entries in the appropriate directory. The Import 
directory corresponds to the Microsoft Exchange server, and the Export directory corre-
sponds to the Scalix server.

4. Accept previous error and update directory

Select this option only when you want to accept errors that occur during the synchroni-
zation process. Accepting errors causes omldapsync to disregard the error condition dur-
ing future directory synchronizations.

Correcting errors typically involves modifying one or more directory entries on the 
Scalix or Microsoft Exchange server.

5. Skip previous error and update directory

6. Update the directory and prompt for error

7. Modify all sync records from the directory

8. Delete all sync records in the directory

d. Toggle debug mode from current setting <0>

n. Toggle test mode from current setting <>

q. Quit

2 Enter the appropriate number to proceed.

Command-Line Options

This section outlines options that can be used with the omldapsync command. If you want 
more control over the process, use them with omldapsync instead of the interactive menu.

To use the omldapsync command with options

1 Enter the command, followed by an option:

omldapsync -i <syncid>

where syncid is the name of the synchronization agreement that you created. The 
options are outlined in the table. You can also view them in the omldapsync MAN page.

Table 1: omldapsync Options

Parameter Description

-s <syncid>
Displays details of the agreement. If the synchronization agreement specified does not exist or is specified 
as “all”, then all available synchronization agreements are listed. Otherwise, the most recent log file con-
tent for the synchronization agreement is displayed.

-c <syncid> Configures a synchronization agreement. If the synchronization agreement specified does not exist, you 
are prompted to create a new agreement.

-r <syncid> Deletes synchronization agreement information. All files and data associated with this agreement are 
deleted from the Scalix server. Imported and exported directory entries are not deleted.

-i <syncid> Displays the interactive menu for the agreement.
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Command Examples

To list all agreements present on the system, enter:

omldapsync -s all

To configure a new or existing agreement named “100”, enter:

omldapsync -c 100

To interactively choose common tasks for agreement 100, enter:

omldapsync -i 100

To load directories for the first time with agreement 100, and use debug level 3, enter:

omldapsync -l 100 -d 3

To accept previous errors and update the import directory with agreement 100, enter:

omldapsync -u 100 -I -A

-l <syncid>

Deprecated; add the -L flag to the -u option.
Loads the directories using the synchronization agreement. This option is used to populate the directories 
with the initial contents of each system for the first time. If -I is used in with the -l option, an import occurs. 
Using -E with -l option executes an export to the Microsoft Exchange server. Using the -l option exclusively 
executes both an import and an export.
You can use this option to resynchronize information, but you must first manually delete the already 
imported and exported entries.

-u <syncid>

Updates the directories using the synchronization agreement. Use this option to keep the directories up-to-
date. Use this option after the first-time synchronization (the -l option).
If -I is used in with the -u option, an import occurs. Using -E with -u option executes an export to the 
Microsoft Exchange server. Using the -l option exclusively executes both an import and an export.
Add the -A option to accept previously reported errors.
Add the -S option to skip previously reported errors.
Add the -P option to force a prompt to accept each error.
Add the -L option to force (re)load of the directory.
Add the -M option to force modification of all entries in the directory.
Add the -X option to delete all entries in the directory.
Use a system scheduler such as cron to update directories on a regular (hourly, daily, weekly, and so on) 
basis.

-d level

Debugs the command execution. The default level is 0, which generates status and information messages. 
To generate more messages for debugging purposes, set the level to 1, 3, 7, or 15. The greater the value 
you enter, the more output the command produces. This can reduce the performance and create large log 
files.
Output for last execution of omldaputil is saved in the omldaputil.log file in the respective import or export 
directory.

-n Show output without performing the real operation. Can be used for a test run to perform a safety check 
before a real run.

Table 1: omldapsync Options

Parameter Description
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	1 Log in to Scalix server as root.
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	7 You are prompted if you want to use the VI editor:
	8 You are prompted about the Java home directory:
	9 You are prompted to identify the Microsoft Exchange server:
	10 You are prompted to identify the Microsoft Exchange Administrator account to use:
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	12 When omldapsync displays the following information:
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	18 When omldapsync displays the following information:
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	Introduction
	Synchronizing the Directories
	1 Log in to the Scalix server.
	2 To execute omldapsync in interactive mode, enter this command:
	3 When the omldapsync menu appears:
	1 Execute omldapsync by entering the following command:
	2 When the menu appears, enter 3.
	3 If you intentionally added the Exchange Distribution List knowing that omldapsync generates errors in this situation, you can “accept” the error by entering the following at the omldapsync prompt:
	4 When the omldapsync menu appears, enter 4 to accept the error and update the directory.

	Resetting a Synchronization
	1 Create a file with the name of all of the mailboxes that were to have been synchronized in the first attempt. To do so, run this command:
	2 Use your preferred editor and open the allmailboxes.out file that is in your home folder.
	3 Delete the lines that contain the two system accounts: sxadmin and sxqueryadmin because you do not want to delete them along with the others.
	4 Purge the other mailboxes by running this command:
	5 To create a new list of directory entries that you want to migrate to mailboxes, run this command:
	6 Use your editor to open this newly created file and remove the following entries:
	7 Run the original ommigu command with this new input file, as shown here:
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	Exporting Public Folders from Microsoft Exchange
	1 Using a “Microsoft Exchange” profile, start the Microsoft Outlook client. This allows you to connect to the Microsoft Exchange server as a public folder owner.
	2 Choose File > Import/Export. A wizard appears.
	3 Select Export to a File, and click Next. The Export to a File screen appears.
	4 Select Personal Folder File (.pst), and click Next. The Export Personal Folders screen appears.
	5 Navigate to the folder into which you copied the Microsoft Exchange public folders that you want to migrate (“Clean and migrate”).
	6 Check the Include Subfolders check box.
	7 Click Next. The Export Personal Folders screen appears.
	8 Enter a name for the file (in the format “file_name.pst”) and specify a folder location in which to save the file. Write down the file name and location pathway for future reference.
	9 Click Finish. A window appears.
	10 If you have concerns about the vulnerability of your public folder data, enter a password for the .pst file.
	11 Click OK to proceed.
	12 A series of export status windows appears, representing the contents of each folder. Upon completion, you can import the .pst file to the Scalix server (next section).

	Importing Public Folders for Scalix
	1 Using a Scalix profile, start Microsoft Outlook. This allows you to log in as a public folder owner on the Scalix server.
	2 In the folder list, select Public Folders.
	3 Choose File > Import/Export. A wizard appears.
	4 Select Import from Another Program or File, and click Next. The Import a File screen appears.
	5 Select Personal Folder File (.pst), and click Next. The Import Personal Folders screen appears.
	6 Click Browse, and locate and select the file that you created previously.
	7 Enable the Replace Duplicates with Items Imported option.
	8 Click Next. The Import Personal Folders screen appears.
	9 Use the explorer view to locate and select the top-level folder (“clean and migrate”) that contains the public folder(s) you want to migrate.
	10 Enable the check box by Include subfolders.
	11 Enable the Import items into the same folder option.
	12 Select Mailbox - username from the drop-down list.
	13 Click Finish.
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	Introduction
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	1 Log in to Scalix.
	2 Open a terminal window and enter the following:
	3 Use these two commands to assess the results in Scalix.

	Verifying the New Mailbox
	1 Start Microsoft Outlook, using a Scalix profile.
	2 Set up an account for the new mailbox.
	3 Log in to that mailbox.
	4 Choose Tools > Send/Receive. This verifies a connection to the server.
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	Introduction
	Removing the Forwarding Address
	1 Log in to Scalix.
	2 Open a terminal window and enter the following:
	3 To run omldapsync in interactive mode, enter the following:
	4 At the prompt, enter 3 to update the directory. The results scroll on-screen.


	Task 7: Configuring Message Forwarding from Exchange to Scalix
	Introduction
	Adding Alternate Recipient Information for a Single Mailbox
	1 Start either the Microsoft Exchange Administration (for Microsoft Exchange 5.5) or System Manager application (for Microsoft Exchange 2000, 2003, or 2007).
	2 Open the Site > Recipients list (or whichever list you have created) for your Microsoft Exchange site.
	3 Locate the first mailbox associated with a user you are migrating to Scalix server, and double-click the entry. A properties window appears.
	4 Click the Delivery Options tab.
	5 Click the Modify button. The Mailbox window appears.
	6 Make sure Global Address Files is selected in the drop-down list at the top right.
	7 Scroll through the left-hand column and find the directory entry with a globe icon that has the same name as the user’s mailbox.
	8 Select the globe entry and click Add. The selected directory entry appears in the column to the right.
	9 Click OK to close the Mailbox window.
	10 When the properties window reappears, click OK to put the custom recipient entry into effect.

	Adding Alternate Recipient Information for Several Mailboxes
	1 Start either the Microsoft Exchange Administration (for Microsoft Exchange 5.5) or System Manager application (for Microsoft Exchange 2000, 2003, or 2007).
	2 Choose Tools > Directory Export. The Directory Export window appears.
	3 To create a directory export file of Microsoft Exchange mailboxes, make these entries:
	4 Click Export to start the process.
	1 Start Microsoft Excel.
	2 Choose File > Open, and open the output file from your directory export.
	3 Choose File > Save As. The Save As window appears.
	4 Save the file with a different file name.
	5 Verify that the output file ends with column M, and that column N is empty.
	6 In cell N1 (of column N), type “Alternate Recipient” as the column header.
	7 Save these changes.
	1 With your exported directory output file open in Excel, enter the following string at the bottom of the spreadsheet (in the first empty row below all existing entries):
	2 Enter a concatenation formula in cell N2 that adds the string from the static cell and the value in column E. For example, if you enter static data in cell A120, cell N2 must have the following formula:
	3 Apply the same formula for all other entries in column N. Select (highlight) cell N2 and press Ctrl+c to copy the contents. Highlight all the other entries in column N and press Ctrl+v to paste the contents.
	4 Verify the accuracy of the data, then choose File > Save As to save the file with a different name. Make sure you click Yes at the Retain the Format prompt.
	5 Choose Tools > Import > Select File to import the file into Microsoft Exchange.


	Task 8: Migrating Mailbox Data
	Requirements
	Introduction
	Extracting Microsoft Exchange Mailbox Data
	1 At the Microsoft Exchange server containing the mailboxes you want to migrate, run exmerge.exe.
	2 In the welcome screen, click Next.
	3 At the next screen, select the Two step merge option and click Next.
	4 At the next screen, select Copy data to Personal Folders and click Next.
	5 At the next screen, enter the name of the Microsoft Exchange server from which you want to extract mailbox data and click Next.
	6 The next screen prompts for the mailboxes you want to merge. Choose specific mailboxes or all mailboxes.
	7 At the next prompt, select the destination directory to write the .pst files to.
	8 The final screen shows a progress bar and ultimately completes, after which you can click Finish. At this point the .pst files have been created in the target directory specified on the prior screen.

	Copying .pst Files into Scalix
	Creating the Target Mailboxes
	Running the Scalix Migration Tool
	1 Download the tool on the Windows migration workstation (in C:\SMT or elsewhere) and unzip.
	2 Run several test mailbox migrations individually. The mailbox must already exist on Scalix. Typically ExMerge names the .pst file with the RDN attribute of the given mailbox (ldapsearch it; you will see).
	3 Once you successfully migrate several individual mailboxes, try a small batch.
	4 When that succeeds, try a larger batch.

	Additional Notes

	Task 9: Decommissioning Microsoft Exchange Mailboxes
	Introduction
	Decommissioning a Mailbox
	1 Start the Microsoft Exchange Administration application.
	2 Open the container (by default, “Recipients”) containing the migrated mailboxes.
	3 Double-click any mailbox entry, to open the Properties window.
	4 Click the Advanced tab.
	5 Enable the Hide from address book check box.
	6 Click OK to save the change and close the window.

	Decommissioning Multiple Mailboxes
	1 Open the backup file you created previously.
	2 Verify that Column M contains a header named Hide from AB (address book) and has a value of 0 (zero).
	3 Change the value in column M to 1.
	4 Save the file.
	1 Start the Microsoft Exchange Administration application.
	2 Click Tools > Directory Import. The Directory Import window appears.
	3 Choose from the following options:
	4 Click Import. A status window appears and closes when the task is complete.
	1 Start the Microsoft Exchange Administration application or Microsoft Outlook.
	2 Verify that the mailboxes are no longer visible in the Microsoft Exchange GAL.
	Part 3
	Phased Migration from Microsoft Exchange to Scalix


	How Phased Migration Works
	Introduction
	Figure 1: Use Different Domain Names

	Mailbox Management During Coexistence
	Coexistence in a Single Picture

	Task 1: Activating Auto-Forwarding on Microsoft Exchange
	Requirements
	Activating Auto-Forwarding on Microsoft Exchange
	1 Start the Microsoft Exchange Administrator application.
	2 Select the site to be migrated, and then choose File > New Other > Recipients Container. A blank properties window appears.
	3 Enter a name for the new recipient container (for example, Scalix Mail Users) in both the Display name and Directory name fields.
	4 Click OK. After a pause for processing, the new container name appears in the Microsoft Exchange Administration explorer view.
	5 In the main Microsoft Exchange Administration window, click the Connections button in the toolbar (second last in the figure shown here).
	6 Click the Connections node in the explorer view.
	7 Double-click Internet Mail Service in the listing on the right. The Internet Mail Service Properties window appears.
	8 Click the Internet Mail tab, if it is not already in view.
	9 Click the E-Mail Domain button. The E-mail Domain window appears.
	10 Click Add. The Add E-Mail Domain window appears.
	11 In the E-Mail Domain field, enter the fully qualified domain name (host.domain.ext) of the destination Scalix server.
	12 Click the Advanced options button. The Advanced options window appears.
	13 From the Send Microsoft Exchange rich text formatting drop-down list, select Always.
	14 Disable the Disable Automatic Replies to the Internet check box.
	15 Click OK to close this window.
	16 Click OK to close each of the other open windows. An alert window appears, prompting you to restart the Internet Mail Service.
	17 Click OK to close this window.
	1 Open the Services control panel; click Start > Settings > Control Panel > Services. The Services control panel appears.
	2 Locate and select the Microsoft Exchange Internet Mail Service.
	3 Click Stop.
	4 Leave the Services control panel open, and, after the “Started” notation is erased from Microsoft Exchange, restart the service by selecting the name and clicking Start.


	Task 2: Preparing the Microsoft Exchange Users Distribution List
	Creating the Microsoft Exchange Users Distribution List
	1 On the Microsoft Exchange server, start the Microsoft Exchange Administrator application.
	2 Select a container that contains Microsoft Exchange users you want to migrate.
	3 Select File > New Distribution List. A blank Properties window appears.
	4 Enter Exchange Users in both the Display name and Alias name fields.
	5 Click the Modify button in the Members area. A distribution list window appears.
	6 Select all the Microsoft Exchange users in the Global Address List (left column) and click Add. The selected names appear in the right column as Distribution List members.
	7 Click OK to close this window and save your entry. Depending upon the number of users in your system, this can take some time to complete.
	8 Click OK to close each of the remaining Microsoft Exchange Administration windows.


	Task 3: Configuring a TNEF route for Microsoft Exchange Users
	Introduction
	Configuring TNEF Routes
	1 Log in to the Scalix server, and open a terminal window.
	2 Enter this command:
	3 Enter this command:
	4 To verify the existence and content of the route, re-enter the omshowrt command:
	5 To verify the route configuration, enter this command:
	6 Make sure that internet,tnef is listed as the TNEF Mailnode attribute. This ensures that TNEF routing is enabled.
	7 To list and verify the mail routes to the UNIX queue for SMTP delivery, enter this command:
	8 To verify the routing configuration, send a test e-mail message to both of the following:


	Task 4: Changing the LDAP Setting on the Scalix Server
	Task 5: Creating the Synchronization Agreement
	Task 6: Completing the Initial Directory Synchronization
	Task 7: Updating Microsoft Exchange and Scalix Directories
	Updating Microsoft Exchange and Scalix Directories
	1 Log in to the Scalix server.
	2 Run omldapsync in interactive mode by entering the following command:
	3 Enter 3 to update the directories.
	4 The results scroll on-screen. When the update completes, you are prompted to exit.


	Task 8: Updating the Client Directory Access
	Updating the Client Directory Access Index
	1 Log in to the Scalix server.
	2 Enter the following command:


	Task 9: Hiding Directory Entries in Scalix Server
	Hiding Directory Entries in Scalix
	1 Enter the following command (example):
	2 To hide the COMMON-NAME=AdminSch=Microsoft Schedule+ Free\/Busy Connector (BAMEX55) directory entry, enter:
	3 To update the client directory access (CDA) directory, enter:


	Task 10: Preparing for Public Folder Migration
	Introduction
	Determining Which Public Folders to Migrate
	Resetting Permissions on Public Folders
	Reorganizing Public Folders and Data
	1 Using a Microsoft Exchange profile, log in to Microsoft Outlook as the designated public folders owner.
	2 Click the All Public Folders folder (inside Public Folders).
	3 Choose File > Folder > New Folder. The Create New Folder window appears.
	4 Enter Clean and Migrate in the Name field.
	5 Click OK.
	6 When the Microsoft Outlook window reappears, right-click the Clean and Migrate folder and choose Properties. A properties window appears.
	7 Make sure the following settings are in effect:
	8 Click OK to save your settings and close the window.
	9 Right-click all of the to-be-migrated public folders and drag them onto the Clean and Migrate folder.
	10 At the prompt, click Copy. The contents of all public folders are copied into this migration folder.

	Creating Public Folders on Scalix Server
	1 Enter the omaddbb command, for example:
	2 To create a subfolder, use the command
	1 Click File > New > Folder. In the window that appears, type a name for the entry, select an option from the drop-down list (e-mail and posts, contacts, or calendars), then click Public Folders to create it there.
	2 Click OK to exit from the window and create the folder.
	3 Create the rest of the folders.
	Figure 1: Changing “Default” Permissions for Regular Users

	Checking Your Work
	1 Start Microsoft Outlook, using the Scalix profile.
	2 Open the public folders list.
	3 Verify that the folders have been migrated from the Clean and Migrate folder.
	1 Run one of the following commands.


	Task 11: Migrating Public Folders
	Task 12: Enabling Public Folder Forwarding on Scalix Server
	Introduction
	Setting Up Forwarding
	1 Run the omaddent command in the following format:
	1 Enter the following command:

	Activating Forwarding
	Testing Your Work

	Task 13: Enabling Public Folder Forwarding on Microsoft Exchange
	Introduction
	Requirements
	Activating Folder Forwarding
	1 Start Microsoft Outlook as the owner of a Microsoft Exchange-based public folder.
	2 Right-click the public folder and choose Properties. The properties window appears.
	3 Click the Administration tab.
	4 Click Folder Assistant. The Folder Assistant window appears.
	5 Click Add Rule. The Edit Rule window appears.
	6 Click From. The Choose Sender window appears.
	7 Make sure Global Address List is selected in the Show Names from drop-down list.
	8 Select a Microsoft Exchange distribution list (represented by two-headed icons) whose users you want to allow to post to public folders.
	9 Click From to move that list to the right area.
	10 Repeat this process to add other lists.
	11 Click OK to save the selections and close the Choose Sender window. The Edit Rule window reappears, displaying the selected groups.
	12 Enable the Forward check box.
	13 From the Method drop-down list, select Leave Message Intact.
	14 In the To field, enter the Internet address of the similarly named public folder stored on Scalix.
	15 Click OK to close the window and save the entries.
	16 Click OK to close all other windows.
	17 To test the success of your efforts, post a new message to a Microsoft Exchange public folder, then see if it is visible in the corresponding Scalix public folder.


	Task 14: Effective Distribution List Coexistence
	Introduction
	Creating the Distribution List and Custom Recipient
	1 Start the Microsoft Exchange Administrator application.
	2 Select the container from which you migrated Microsoft Exchange users (for example, Recipients).
	3 Choose File > New Distribution List. A Properties window appears.
	4 Click the Modify button in the Members area.
	5 Add all Scalix users to the Distribution List.
	6 Enter a name in the Display name field.
	7 Enter a name in the Alias name field. (It does not have to be different.)
	8 Click OK to save your entries and close the properties window.
	1 Log in to Scalix.
	2 Enter the following omldapsync directory-update command:
	3 When the omldapsync menu appears, enter 3 to update the directory.
	1 Enter this command:


	Task 15: Loading Scalix Mailboxes
	Task 16: Bulk Mailbox Provisioning and Configuration
	Introduction
	Using Microsoft Exchange Attributes to Provision Scalix Mailboxes
	1 Use the –ldapfilter option as follows:
	2 Configure these user accounts for use with Scalix by entering:
	3 Execute omldapsync in interactive mode by entering:
	4 At the prompt, enter 3 to update the directory.

	Using Scalix Server Attributes to Provision Scalix Mailboxes
	1 Provision all users (mailboxes) in the Scalix directory with the given name of Mark by entering:
	2 Because the LDAP representation of this field is givenName, you can also provision the Microsoft Exchange server for all directory objects with a given name of Mark. To do so, enter the following command:
	3 Configure these user accounts for use with Scalix by entering:
	4 Execute omldapsync in interactive mode by entering:
	5 At the prompt, enter 3 to update the directory.

	Using the Userfile Option to Provision Scalix Mailboxes
	1 Using the Microsoft Exchange Administration application, extract the current users to a comma-separated file.
	2 Edit the file to remove the user accounts that you do not want to migrate.
	3 Save the file in .txt format, using the .txt extension.
	4 Provision the mailboxes in this list by entering this command:
	5 Configure these users for use with Scalix server by entering:
	6 Run omldapsync in interactive mode by entering:
	7 At the prompt, enter 3 to update the directory.

	If You are Asked for Passwords
	1 If this prompt appears after you have entered 3:
	2 When this prompt appears:


	Task 17: Reconfiguring Auto-Forward for the New Scalix Mailboxes
	Task 18: Configuring Message Forwarding from Exchange to Scalix
	Task 19: Migrating Mailbox Data
	Task 20: Decommissioning Microsoft Exchange Mailboxes
	Task 21: Post-Migration and Coexistence Closure Tasks
	Achieving Successful Coexistence
	Managing Distribution Lists
	Switching Distribution List Management to Scalix
	1 Create a custom recipient pointing to the Scalix group; in the Microsoft Exchange Administrator application, choose File > New Custom Recipient. The New E-mail Address window appears.
	2 Select Internet Address and click OK. The Internet Address Properties window appears.
	3 In the E-mail address field, type the Scalix group’s full e-mail address, for example sales@mailserver.scalix.company.com
	4 Click OK to proceed. The Properties window appears.
	5 Click the Display field and type the Scalix group’s name (probably the same name as the original Microsoft Exchange PDL).
	6 Click the Alias field and type the scalix group’s full e-mail address. Ignore all the other fields.
	7 Click Apply, then click OK, to close this window and save your entries.
	8 When Microsoft Exchange reappears, open the Lists menu and choose Custom Recipients. The new custom recipient appears in the now-visible list.
	9 Remove the Microsoft Exchange auto-forward from the Scalix group/Public Distribution List that refers to the original Microsoft Exchange Public Distribution List.
	10 Set up the auto-forwarding for the Microsoft Exchange group; in Microsoft Exchange Administrator, double-click the original PDL entry to open that list’s properties window.
	11 Click the Modify button below the users list. The Distribution List window appears.
	12 Select and delete all the entries in the Distribution List Members list.
	13 In the same window, locate the custom recipient (representing the Scalix group).
	14 Select it and click Add ->.
	15 Click OK to save the change and close the window.
	16 When the Properties window reappears, click Apply, then click OK to save your changes.
	17 Now hide the custom recipient from Microsoft Exchange view. First, start the Microsoft Exchange Administrator application.
	18 Open the List menu (on the Microsoft Exchange Administrator toolbar) and choose Custom Recipients.
	19 Locate and double-click the Scalix-group custom recipient in the list that appears.
	20 When the Properties window appears, click the Advanced tab.
	21 In the Custom Recipient Options, enable the Hide from address book check box.
	22 Click Apply to activate your changes, then click OK to close the properties window.
	23 You can exit the Microsoft Exchange Administrator application.

	Switching PDL Management After Coexistence
	1 In the Microsoft Exchange Administrator application, open the Recipients container where the Distribution Lists are stored.
	2 Right-click the appropriate Distribution List entry and select Properties. The Properties window opens.
	3 In the General tab, click Modify. A Distribution List window appears.
	4 Select all of the list’s users (by clicking the Members list and pressing Ctrl+A) and copy them to the Windows clipboard.
	5 Close the Distribution List and Properties windows.
	6 Open a new Notepad or Wordpad document and paste the collection of user information into the document window.
	7 Save this document as Dlist.txt
	8 Exit the Microsoft Exchange Administrator application.
	1 Open a new Excel workbook, with the active cell being A1.
	2 Click Data > Import External Data > Import Data. The Select Data Source window appears.
	3 Locate and select the user names text file.
	4 Click Open. The Text Import wizard appears.
	5 In the first wizard screen, click the Delimited button.
	6 Click Next. The second wizard screen appears.
	7 Enable the Delimited check box and uncheck any others.
	8 Make sure that both first and last names are sorted into the same cell/column as shown in the preview area of the window.
	9 Click Next. The third wizard screen appears. No changes are needed.
	10 Click Finish. The Import Data window appears.
	11 Click OK. (The default location is the current worksheet, in cell =$A$1.) Row 1 displays names from the list, one first/last name pairing per cell.
	12 Select the entire row. (Selecting empty cells does not affect this procedure.)
	13 Copy the row’s contents to the Windows clipboard.
	14 Open a new Excel workbook.
	15 Click Edit > Paste Special. The Paste Special window appears.
	16 Enable the Transpose check box. (All other default settings are acceptable.)
	17 Click OK to complete the pasting of data. Excel redistributes the first and last names in Column A.
	18 Due to the default column width, the name entries can appear to spill into column B and C. Widen Column A to verify that each first/last name entry fits in its own Column A cell.
	19 Save this file/workbook as a text file for importation into Scalix.
	20 Print the file.

	Continuing Coexistence
	1 Log in to Scalix as root.
	2 Use a text editor to open the snapshot file that contains the original “Jane Smith” record.
	3 Find and delete the “Jane Smith” record and the following carriage return.
	4 Save the change to the snapshot file.
	5 Restart omldapsync. After comparing the latest collection of user records with the previous snapshot, it creates a [name] file that replaces the missing “Jane Smith” record on the destination server.
	Part 4
	Migrating an IMAP System to Scalix


	Completing an IMAP-to-IMAP Mail System Migration
	Requirements
	Installing E-Mail Shuttle
	1 Launch the E-Mail Shuttle installation wizard. You can accept the default directory or change it to C:\Program Files. Also be sure to choose the following:

	Configuring E-Mail Shuttle
	1 Click Start > All Programs > GeM Solutions, Inc > GeM E-Mail Shuttle > GeM E-Mail Shuttle Extractor > GeM E-Mail Shuttle Mission Control for IMAP4. The IMAP Extract Mission Control window appears. The default settings in the tabs are acceptable, wi...
	2 Click the Misc tab.
	3 In the Authorization Code field, type the extractor code if it is not already entered.
	4 Click the IMAP 4 tab.
	5 In the Host Name field, type the fully-qualified domain name of the legacy IMAP4 server.
	6 Click OK to update the \eshuttle\Extractor\IMAP4\eshuttle.ini file with your new entries and exit the application.

	Loading the Mailboxes on the Scalix Server
	1 Start the Shuttlin Editor from the Start menu (... > Tools > GeM E-Mail Shuttle Shuttlin File Editor). The Shuttlin Editor window appears.
	2 Click File > Open/New. A window opens.
	3 Use the window to navigate to the target folder:
	4 Enter a name for the file in the File name field, ending the filename with a “.txt” extension. Make sure the file type is “Text file”.
	5 Click Open. The Select Shuttlin file type window opens.
	6 Enable the IMAP option.
	7 Click OK to save the file type selection. The Shuttlin Editor window reappears, displaying the new file name in the title bar.
	8 Complete the following fields to add information for a current user:
	9 Click Add to store this user’s information.
	10 Save the file; click File > Save.
	11 Exit from the application; click File > Exit.

	Extracting the Mailbox Contents
	1 To run this application, either click the .exe file, or open a command window, change to the directory, and type

	Loading the Extracted Data onto Scalix
	1 To run this application, click the .exe file, or open a command window and enter
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	omldapsync Synchronization Command
	Introduction
	Using the omldapsync Command
	1 To execute omldapsync in interactive mode and perform omldapsync tasks, enter the following command:
	2 Enter the appropriate number to proceed.

	Command-Line Options
	1 Enter the command, followed by an option:

	Command Examples


